summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-05-27 16:04:58 +0200
committerLW-archlinux2019-05-27 16:04:58 +0200
commit4f2ecf85d5da60c73e5022dd1312b00611786771 (patch)
treede28c03071d84258b6a6742221994ec01d072b3e
parent7fea2aeaa7510f1f7481cac07ffcf4a3f68e7593 (diff)
downloadaur-4f2ecf85d5da60c73e5022dd1312b00611786771.tar.gz
make sure python3 is used, even if python2 is present
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD28
2 files changed, 34 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ef7df95d365..def11e870e33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 9.0.0_r315275.99bad370134
+ pkgver = 9.0.0_r317457.5a500fd2c50
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -28,23 +28,23 @@ pkgbase = llvm-git
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git
+ depends = llvm-libs-git=9.0.0_r317457.5a500fd2c50-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit (LLVM Integrated Tester)
optdepends = ocaml: for ocaml support
- provides = compiler-rt-git=9.0.0_r315275.99bad370134-1
- provides = clang-git=9.0.0_r315275.99bad370134-1
- provides = lld-git=9.0.0_r315275.99bad370134-1
- provides = lldb-git=9.0.0_r315275.99bad370134-1
- provides = polly-git=9.0.0_r315275.99bad370134-1
- provides = llvm-ocaml-git=9.0.0_r315275.99bad370134-1
- provides = compiler-rt=9.0.0_r315275.99bad370134-1
- provides = clang=9.0.0_r315275.99bad370134-1
- provides = lld=9.0.0_r315275.99bad370134-1
- provides = lldb=9.0.0_r315275.99bad370134-1
- provides = polly=9.0.0_r315275.99bad370134-1
- provides = llvm-ocaml=9.0.0_r315275.99bad370134-1
+ provides = compiler-rt-git=9.0.0_r317457.5a500fd2c50-1
+ provides = clang-git=9.0.0_r317457.5a500fd2c50-1
+ provides = lld-git=9.0.0_r317457.5a500fd2c50-1
+ provides = lldb-git=9.0.0_r317457.5a500fd2c50-1
+ provides = polly-git=9.0.0_r317457.5a500fd2c50-1
+ provides = llvm-ocaml-git=9.0.0_r317457.5a500fd2c50-1
+ provides = compiler-rt=9.0.0_r317457.5a500fd2c50-1
+ provides = clang=9.0.0_r317457.5a500fd2c50-1
+ provides = lld=9.0.0_r317457.5a500fd2c50-1
+ provides = lldb=9.0.0_r317457.5a500fd2c50-1
+ provides = polly=9.0.0_r317457.5a500fd2c50-1
+ provides = llvm-ocaml=9.0.0_r317457.5a500fd2c50-1
provides = llvm-svn
provides = compiler-rt-svn
provides = clang-svn
@@ -69,7 +69,7 @@ pkgname = llvm-libs-git
depends = libedit
depends = ncurses
depends = libxml2
- provides = llvm-libs=9.0.0_r315275.99bad370134-1
- provides = llvm-libs-svn=9.0.0_r315275.99bad370134-1
+ provides = llvm-libs=9.0.0_r317457.5a500fd2c50-1
+ provides = llvm-libs-svn=9.0.0_r317457.5a500fd2c50-1
conflicts = llvm-libs
diff --git a/PKGBUILD b/PKGBUILD
index 420af4fee5cd..2b891e4f93b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
pkgname=('llvm-git' 'llvm-libs-git')
-pkgver=9.0.0_r315275.99bad370134
+pkgver=9.0.0_r317457.5a500fd2c50
pkgrel=1
_ocaml_ver=4.07.1
arch=('x86_64')
@@ -80,6 +80,7 @@ build() {
cmake "$srcdir"/llvm-project/llvm -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -D PYTHON_EXECUTABLE=/usr/bin/python \
-DLLVM_APPEND_VC_REV=ON \
-DLLVM_HOST_TRIPLE=$CHOST \
-DLLVM_ENABLE_RTTI=ON \
@@ -108,18 +109,19 @@ build() {
check() {
cd _build
- # Dirty fix for unittests failing because the shared lib is not in the library path.
- # Also, disable the LLVM tests on i686 as they seem to fail too often there.
- [[ "$CARCH" == "i686" ]] || LD_LIBRARY_PATH="$srcdir"/_build/lib ninja check
- ninja check-clang
- ninja check-polly
- ninja check-lld
- ninja check-lldb
+ if [[ ! $NINJAFLAGS ]]; then
+ ninja check check-polly check-lld check-lldb check-clang
+ else
+ ninja "$NINJAFLAGS" check check-polly check-lld check-lldb check-clang
+ fi
+
+
+
}
package_llvm-git() {
pkgdesc="LLVM development version. includes clang and many other tools"
- depends=('llvm-libs-git' 'perl')
+ depends=(llvm-libs-git=$pkgver-$pkgrel 'perl')
optdepends=( 'python: for scripts'
'python-setuptools: for using lit (LLVM Integrated Tester)'
'ocaml: for ocaml support')
@@ -132,7 +134,13 @@ package_llvm-git() {
pushd _build
- DESTDIR="$pkgdir" ninja install
+ if [[ ! $NINJAFLAGS ]]; then
+ DESTDIR="$pkgdir" ninja install
+ else
+ DESTDIR="$pkgdir" ninja "$NINJAFLAGS" install
+ fi
+
+
popd
# Clean up conflicting files