summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-11-18 12:36:29 +0100
committerLW-archlinux2019-11-18 12:36:29 +0100
commitbcee49b510a96b886ee6ea184ee90805ed3bd312 (patch)
tree402fe4edcb345d1bc5663a04dd9ac905a2d6a49d
parentc4d49c5326f4c7d173bdb4357079cc015bc8c9bb (diff)
downloadaur-bcee49b510a96b886ee6ea184ee90805ed3bd312.tar.gz
added llvm-ocaml-git to pkgname array so it does get build, updated conflicts & provides
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD11
2 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 184358caab5..ee5b0059872 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 10.0.0_r331734.86f07e826f4
+ pkgver = 10.0.0_r332048.eedb9648229
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -32,29 +32,27 @@ pkgbase = llvm-git
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=10.0.0_r331734.86f07e826f4-1
+ depends = llvm-libs-git=10.0.0_r332048.eedb9648229-1
depends = perl
- depends = ocaml=4.09.0
optdepends = python: for scripts
optdepends = python-setuptools: for using lit = LLVM Integrated Tester
provides = aur-llvm-git
- provides = compiler-rt-git=10.0.0_r331734.86f07e826f4-1
- provides = clang-git=10.0.0_r331734.86f07e826f4-1
- provides = lld-git=10.0.0_r331734.86f07e826f4-1
- provides = lldb-git=10.0.0_r331734.86f07e826f4-1
- provides = polly-git=10.0.0_r331734.86f07e826f4-1
- provides = compiler-rt=10.0.0_r331734.86f07e826f4-1
- provides = clang=10.0.0_r331734.86f07e826f4-1
- provides = lld=10.0.0_r331734.86f07e826f4-1
- provides = lldb=10.0.0_r331734.86f07e826f4-1
- provides = polly=10.0.0_r331734.86f07e826f4-1
+ provides = compiler-rt-git=10.0.0_r332048.eedb9648229-1
+ provides = clang-git=10.0.0_r332048.eedb9648229-1
+ provides = lld-git=10.0.0_r332048.eedb9648229-1
+ provides = lldb-git=10.0.0_r332048.eedb9648229-1
+ provides = polly-git=10.0.0_r332048.eedb9648229-1
+ provides = compiler-rt=10.0.0_r332048.eedb9648229-1
+ provides = clang=10.0.0_r332048.eedb9648229-1
+ provides = lld=10.0.0_r332048.eedb9648229-1
+ provides = lldb=10.0.0_r332048.eedb9648229-1
+ provides = polly=10.0.0_r332048.eedb9648229-1
conflicts = llvm
conflicts = compiler-rt
conflicts = clang
conflicts = lld
conflicts = lldb
conflicts = polly
- conflicts = llvm-ocaml
pkgname = llvm-libs-git
pkgdesc = runtime libraries for llvm-git
@@ -65,6 +63,14 @@ pkgname = llvm-libs-git
depends = ncurses
depends = libxml2
provides = aur-llvm-libs-git
- provides = llvm-libs=10.0.0_r331734.86f07e826f4-1
+ provides = llvm-libs=10.0.0_r332048.eedb9648229-1
conflicts = llvm-libs
+pkgname = llvm-ocaml-git
+ pkgdesc = OCaml bindings for LLVM
+ depends = llvm-git=10.0.0_r332048.eedb9648229-1
+ depends = ocaml=4.09.0
+ depends = ocaml-ctypes
+ provides = llvm-ocaml=10.0.0_r332048.eedb9648229-1
+ conflicts = llvm-ocaml
+
diff --git a/PKGBUILD b/PKGBUILD
index 9b1865cf2f6..ae3d939b7a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,8 @@
# Contributor: Tomas Wilhelmsson <tomas.wilhelmsson@gmail.com>
-pkgname=('llvm-git' 'llvm-libs-git')
-pkgver=10.0.0_r331734.86f07e826f4
+pkgname=('llvm-git' 'llvm-libs-git' 'llvm-ocaml-git')
+pkgver=10.0.0_r332048.eedb9648229
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -124,7 +124,7 @@ check() {
package_llvm-git() {
pkgdesc="LLVM development version. includes clang and many other tools"
- depends=("llvm-libs-git=$pkgver-$pkgrel" 'perl' "ocaml=$(_ocamlver)")
+ depends=("llvm-libs-git=$pkgver-$pkgrel" 'perl')
optdepends=('python: for scripts'
'python-setuptools: for using lit = LLVM Integrated Tester'
)
@@ -134,7 +134,7 @@ package_llvm-git() {
compiler-rt=$pkgver-$pkgrel clang=$pkgver-$pkgrel lld=$pkgver-$pkgrel lldb=$pkgver-$pkgrel polly=$pkgver-$pkgrel
)
# A package always provides itself, so there's no need to provide llvm-git
- conflicts=('llvm' 'compiler-rt' 'clang' 'lld' 'lldb' 'polly' 'llvm-ocaml')
+ conflicts=('llvm' 'compiler-rt' 'clang' 'lld' 'lldb' 'polly')
pushd _build
DESTDIR="$pkgdir" ninja $NINJAFLAGS install
@@ -218,7 +218,8 @@ package_llvm-libs-git() {
package_llvm-ocaml-git() {
pkgdesc="OCaml bindings for LLVM"
- depends=("llvm-git=$pkgver-$pkgrel" "ocaml=$(_ocaml_ver)" 'ocaml-ctypes')
+ depends=("llvm-git=$pkgver-$pkgrel" "ocaml=$(_ocamlver)" 'ocaml-ctypes')
+ conflicts=('llvm-ocaml')
provides=("llvm-ocaml=$pkgver-$pkgrel")
install -d "$pkgdir"/{usr/lib,usr/share/doc/$pkgname}