summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Baumann2023-03-23 18:28:07 +0100
committerAndreas Baumann2023-03-23 18:28:07 +0100
commit9dfd25b77f6e0208242de05f835a07c5b5e48970 (patch)
tree5e96b62e5bfb1471cf7dacaf9d4ade942190b4be
downloadaur-9dfd25b77f6e0208242de05f835a07c5b5e48970.tar.gz
an initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8548b5922160
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = llvm-mos-git
+ pkgver = r452222.b05db96bef68
+ pkgrel = 1
+ url = https://llvm-mos.org/wiki/Welcome
+ arch = x86_64
+ license = custom:Apache 2.0 with LLVM Exception
+ makedepends = cmake
+ makedepends = ninja
+ options = staticlibs
+ options = !lto
+ source = git+https://github.com/llvm-mos/llvm-mos.git
+ sha256sums = SKIP
+
+pkgname = llvm-mos-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c129ce4be727
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=('llvm-mos-git')
+_pkgname=${pkgname%-git}
+pkgver=r452222.b05db96bef68
+pkgrel=1
+arch=('x86_64')
+url="https://llvm-mos.org/wiki/Welcome"
+license=('custom:Apache 2.0 with LLVM Exception')
+makedepends=('cmake' 'ninja')
+options=('staticlibs' '!lto') # Getting thousands of test failures with LTO
+source=(git+https://github.com/llvm-mos/llvm-mos.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ cmake \
+ -S llvm \
+ -G Ninja \
+ -C clang/cmake/caches/MOS.cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/llvm-mos \
+ .
+
+ ninja
+}
+
+check() {
+ cd "$srcdir/$_pkgname"
+ echo "No testing.. takes too long.."
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ DESTDIR="$pkgdir" ninja install
+}