summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2020-04-27 17:06:01 +0100
committerDiab Neiroukh2020-04-27 17:06:01 +0100
commit84767bb2365dfe3e21f4b4ae1a35905f6a751bf0 (patch)
tree415a4b221e6568f9e21a69db72a674cd979e70a1
downloadaur-84767bb2365dfe3e21f4b4ae1a35905f6a751bf0.tar.gz
🔥
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..164d2a905114
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = linux-proton-bin
+ pkgdesc = A LLVM and Clang compiler toolchain built for kernel development
+ pkgver = 11.0.0
+ pkgrel = 1
+ url = https://github.com/kdrag0n/proton-clang
+ arch = x86_64
+ license = custom
+ options = !strip
+ source = https://github.com/kdrag0n/proton-clang/archive/master.zip
+ b2sums = SKIP
+
+pkgname = linux-proton-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c720f66a8527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
+
+pkgname="linux-proton-bin"
+pkgver=11.0.0
+pkgrel=1
+arch=(
+ "x86_64"
+)
+pkgdesc="A LLVM and Clang compiler toolchain built for kernel development"
+url="https://github.com/kdrag0n/proton-clang"
+license=(
+ "custom"
+)
+options=(
+ "!strip"
+)
+source=(
+ "https://github.com/kdrag0n/proton-clang/archive/master.zip"
+)
+b2sums=(
+ "SKIP"
+)
+
+package()
+{
+ install -d "$pkgdir/opt"
+
+ cp -r "proton-clang-master" "$pkgdir/opt/proton-clang"
+}