summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuchesar V. ILIEV2015-09-09 15:35:23 +0300
committerLuchesar V. ILIEV2015-09-09 15:46:49 +0300
commitdb2a8f571d63c53c7887a8e2852ab63867003ca5 (patch)
tree8a7f919046cb187a638f6f1b3561fc2216315b59
parentc974b7f7be791c665264e88649ed9ffcf5c24681 (diff)
downloadaur-db2a8f571d63c53c7887a8e2852ab63867003ca5.tar.gz
Add the missing compiler-rt runtime libraries
While the libraries are part of the official Clang package, we opt for putting them in a separate package, which is how upstream does at http://llvm.org/apt/. This commit solves issue #5.
-rw-r--r--PKGBUILD23
1 files changed, 22 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9a8ce909e2a..c132e2bb95bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,11 +15,12 @@ pkgname=(
'llvm-ocaml-svn'
'clang-svn'
'clang-analyzer-svn'
+ 'clang-compiler-rt-svn'
'clang-tools-extra-svn'
)
_pkgname='llvm'
-pkgver=3.8.0svn_r246942
+pkgver=3.8.0svn_r247138
pkgrel=1
arch=('i686' 'x86_64')
@@ -286,6 +287,9 @@ package_clang-svn() {
"llvm-svn=${pkgver}-${pkgrel}"
)
optdepends=(
+ 'clang-analyzer-svn: source code analysis for Clang, supporting C, C++, and Objective-C'
+ 'clang-compiler-rt-svn: sanitizer runtimes, builtins, profile library and BlocksRuntime'
+ 'clang-tools-extra-svn: standalone tools: syntax checking, formatting, refactoring, etc.'
'python2: git-clang-format and clang-format-diff.py support'
)
provides=('clang')
@@ -348,6 +352,23 @@ package_clang-analyzer-svn() {
_install_license
}
+package_clang-compiler-rt-svn() {
+ pkgdesc='The "compiler-rt" set of runtime libraries for Clang and LLVM'
+ url='http://compiler-rt.llvm.org/'
+ depends=(
+ "clang-svn=${pkgver}-${pkgrel}"
+ )
+ provides=('clang-compiler-rt')
+ replaces=('clang-compiler-rt')
+ conflicts=('clang-compiler-rt')
+
+ cd "${srcdir}/build/projects/compiler-rt"
+
+ make DESTDIR="${pkgdir}" install
+
+ _install_license
+}
+
package_clang-tools-extra-svn() {
pkgdesc='Standalone tools for Clang: syntax checking, formatting, refactoring, etc.'
url='http://clang.llvm.org/docs/ClangTools.html'