summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrommer2022-06-06 23:48:12 +0300
committerDrommer2022-06-06 23:48:12 +0300
commitc755335b970dd7cdef5a0285a7b1959c0669be3b (patch)
tree258baec28d256b535736986d7b41a6a4d35573ef
parent4557cf092af7a130f723afc44ddadd4878906916 (diff)
downloadaur-c755335b970dd7cdef5a0285a7b1959c0669be3b.tar.gz
Fix dependencies mistake
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37c2df86f064..462ec597f8f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,7 +24,7 @@ pkgbase = llvm10
pkgname = llvm10
pkgdesc = Collection of modular and reusable compiler and toolchain technologies
- depends = llvm-libs
+ depends = llvm10-libs
depends = perl
optdepends = python-setuptools: for using lit (LLVM Integrated Tester)
diff --git a/PKGBUILD b/PKGBUILD
index c3b5961527aa..2a3644e8daae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
-makedepends=('cmake' 'ninja' 'libffi' 'libedit' 'ncurses'
+makedepends=('cmake' 'ninja' 'libffi' 'libedit' 'ncurses'
'libxml2' 'python-sphinx' 'python-recommonmark')
options=('staticlibs')
source=("https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver/llvm-$pkgver.src.tar.xz"
@@ -50,7 +50,7 @@ build() {
package_llvm10() {
pkgdesc="Collection of modular and reusable compiler and toolchain technologies"
- depends=('llvm-libs' 'perl')
+ depends=('llvm10-libs' 'perl')
optdepends=('python-setuptools: for using lit (LLVM Integrated Tester)')
cd "$srcdir/llvm-$pkgver.src/build"
@@ -72,7 +72,7 @@ package_llvm10() {
mv "$pkgdir/opt/llvm10/include/llvm/Config/llvm-config"{,-64}.h
cp "$srcdir/llvm-config.h" "$pkgdir/opt/llvm10/include/llvm/Config/llvm-config.h"
fi
-
+
cp -rf "$pkgdir"/usr/{bin,lib} "$pkgdir/opt/llvm10"
rm -rf "$pkgdir"/usr
@@ -93,10 +93,10 @@ package_llvm10-libs() {
# https://bugs.archlinux.org/task/28479
install -d "$pkgdir/opt/llvm10/lib/bfd-plugins"
ln -s ../LLVMgold.so "$pkgdir/opt/llvm10/lib/bfd-plugins/LLVMgold.so"
-
+
install -Dm644 "/dev/null" \
"$pkgdir/etc/ld.so.conf.d/70-llvm10-libs.conf"
-
+
echo "/opt/llvm10/lib" > "$pkgdir/etc/ld.so.conf.d/70-llvm10-libs.conf"
install -Dm644 "$srcdir/llvm-$pkgver.src/LICENSE.TXT" \