summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2020-04-30 00:04:12 +0200
committerAlbert Graef2020-04-30 00:04:12 +0200
commit6ddcff4bf31ae92f9af694ba6c4dda4e1f3cf8a1 (patch)
tree0a56c1eaaac94df556f3aa300a40387ff477c77e
parentf9c19a86a79add1da1e189e7ac960590b1eea550 (diff)
downloadaur-6ddcff4bf31ae92f9af694ba6c4dda4e1f3cf8a1.tar.gz
Remove obsolete python2 dependency. Also needs rebuild after recent libffi update.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 421b8d5d91cc..01bdb7e2456f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,10 @@
-# Generated by mksrcinfo v8
-# Sun Apr 8 08:01:28 UTC 2018
pkgbase = llvm35
pkgver = 3.5.2
- pkgrel = 5
+ pkgrel = 6
url = http://llvm.org/
arch = x86_64
license = custom:University of Illinois/NCSA Open Source License
makedepends = libffi
- makedepends = python2
makedepends = python-sphinx
options = staticlibs
source = https://releases.llvm.org/3.5.2/llvm-3.5.2.src.tar.xz
@@ -26,7 +23,7 @@ pkgbase = llvm35
pkgname = llvm35
pkgdesc = Low Level Virtual Machine
- depends = llvm35-libs=3.5.2-5
+ depends = llvm35-libs=3.5.2-6
depends = perl
conflicts = llvm
@@ -41,7 +38,7 @@ pkgname = llvm35-libs
pkgname = clang35
pkgdesc = C language family frontend for LLVM
url = http://clang.llvm.org/
- depends = llvm35-libs=3.5.2-5
+ depends = llvm35-libs=3.5.2-6
depends = gcc
optdepends = llvm-libs: for compiling with -flto
conflicts = clang
diff --git a/PKGBUILD b/PKGBUILD
index 5c00a367fd16..00661c727139 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,11 +29,11 @@
pkgbase=llvm35
pkgname=('llvm35' 'llvm35-libs' 'clang35')
pkgver=3.5.2
-pkgrel=5
+pkgrel=6
arch=('x86_64')
url="http://llvm.org/"
license=('custom:University of Illinois/NCSA Open Source License')
-makedepends=('libffi' 'python2' 'python-sphinx')
+makedepends=('libffi' 'python-sphinx')
# Use gcc-multilib to build 32-bit compiler-rt libraries on x86_64 (FS#41911)
makedepends_x86_64=('gcc-multilib')
options=('staticlibs')
@@ -96,8 +96,7 @@ build() {
--enable-libffi \
--enable-targets=host \
--disable-assertions \
- --with-binutils-include=/usr/include \
- --with-python=/usr/bin/python2
+ --with-binutils-include=/usr/include
make REQUIRES_RTTI=1
make -C docs -f Makefile.sphinx man