summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Olivier Vauboin2016-12-03 19:02:12 +0100
committerPierre-Olivier Vauboin2016-12-03 19:02:12 +0100
commit809ed7304643f191cc35bb185f7c248c8566c96f (patch)
tree1a95637d1e8e53e1708c6a06b2ac7dd71ae793f3
downloadaur-lm32-elf-gdb.tar.gz
lm32-elf-gdb 7.12 1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b41a02986809
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lm32-elf-gdb
+ pkgdesc = The GNU Debugger for LM32
+ pkgver = 7.12
+ pkgrel = 1
+ url = http://www.gnu.org/software/gdb/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = guile
+ depends = ncurses
+ depends = expat
+ depends = xz
+ options = !emptydirs
+ source = ftp://ftp.gnu.org/gnu/gdb/gdb-7.12.tar.xz
+ source = ftp://ftp.gnu.org/gnu/gdb/gdb-7.12.tar.xz.sig
+ validpgpkeys = F40ADB902B24264AA42E50BF92EDB04BFF325CF3
+ sha256sums = 834ff3c5948b30718343ea57b11cbc3235d7995c6a4f3a5cecec8c8114164f94
+ sha256sums = SKIP
+
+pkgname = lm32-elf-gdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdabe86823e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Pierre-Olivier Vauboin <povauboin@gmail.com>
+
+# Based on avr-gdb
+
+_target=lm32-elf
+pkgname=$_target-gdb
+pkgver=7.12
+pkgrel=1
+pkgdesc='The GNU Debugger for LM32'
+arch=(i686 x86_64)
+url='http://www.gnu.org/software/gdb/'
+license=(GPL3)
+depends=(python guile ncurses expat xz)
+options=(!emptydirs)
+source=(ftp://ftp.gnu.org/gnu/gdb/gdb-$pkgver.tar.xz{,.sig})
+sha256sums=('834ff3c5948b30718343ea57b11cbc3235d7995c6a4f3a5cecec8c8114164f94'
+ 'SKIP')
+validpgpkeys=('F40ADB902B24264AA42E50BF92EDB04BFF325CF3') # Joel Brobecker <brobecker@adacore.com>
+
+prepare() {
+ cd gdb-$pkgver
+
+ # hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+build() {
+ cd gdb-$pkgver
+
+ ./configure \
+ --disable-nls \
+ --enable-languages=c,c++ \
+ --prefix=/usr \
+ --target=$_target \
+ --with-python=/usr/bin/python3 \
+ --with-system-readline \
+ --with-system-gdbinit=/etc/gdb/gdbinit
+
+ make
+}
+
+package() {
+ cd gdb-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Following files conflict with 'gdb' package
+ rm -r "$pkgdir"/usr/share/info
+ rm -r "$pkgdir"/usr/share/man
+ rm -r "$pkgdir"/usr/share/gdb
+ rm -r "$pkgdir"/usr/include/gdb
+}