summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:51:05 +0300
committerYuval Adam2015-06-30 15:51:05 +0300
commitb6fe54decf5065ee97be6d3ae61657d4c6b0b781 (patch)
tree389ee831f4d2f8f8a801ee86550c31d6c6d53976
downloadaur-b6fe54decf5065ee97be6d3ae61657d4c6b0b781.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
3 files changed, 71 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8415600e8422
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = lm4tools-git
+ pkgdesc = A set of tools which enable multi-platform development on the TI Stellaris Launchpad boards
+ pkgver = a565880
+ pkgrel = 1
+ url = https://github.com/utzig/lm4tools
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = make
+ depends = libusb
+ provides = lm4tools
+ source = git+https://github.com/utzig/lm4tools.git
+
+pkgname = lm4tools-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..912dff5c681a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lm4tools-git
+ pkgdesc = A set of tools which enable multi-platform development on the TI Stellaris Launchpad boards
+ pkgver = a565880
+ pkgrel = 1
+ url = https://github.com/utzig/lm4tools
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = make
+ depends = libusb
+ provides = lm4tools
+ source = git+https://github.com/utzig/lm4tools.git
+ md5sums = SKIP
+
+pkgname = lm4tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..745e08849005
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Yuval Adam <yuv dot adm at gmail dot com> PGP-Key: CC2115C12D99D2F0
+
+pkgname=lm4tools-git
+pkgver=a565880
+pkgrel=1
+pkgdesc="A set of tools which enable multi-platform development on the TI Stellaris Launchpad boards"
+arch=('any')
+url="https://github.com/utzig/lm4tools"
+license=('GPL')
+depends=('libusb')
+makedepends=('git' 'gcc' 'make')
+provides=('lm4tools')
+source=('git+https://github.com/utzig/lm4tools.git')
+md5sums=('SKIP')
+_gitname=lm4tools
+_binaries=('lm4flash')
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ for DIR in $_binaries
+ do
+ cd $DIR
+ make
+ done
+}
+
+package() {
+ cd $_gitname
+ for B in $_binaries
+ do
+ install -Dm755 $srcdir/$_gitname/$B/$B $pkgdir/usr/bin/$B
+ done
+}