summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblue2023-03-26 22:24:04 +0300
committerblue2023-03-26 22:24:04 +0300
commit4d497e7c7908db1f6d4a50101f6b962b0405a7bc (patch)
tree76b235e0372c7477f1218b42943efbc9a6631293
downloadaur-4d497e7c7908db1f6d4a50101f6b962b0405a7bc.tar.gz
0.2.0 First pre release of a library
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..361a0c2ba913
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lmdbal
+ pkgdesc = LMDB Abstraction Layer, qt5 version
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://git.macaw.me/blue/lmdbal
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake>=3.16
+ depends = lmdb
+ depends = qt5-base
+ source = lmdbal-0.2.0.tar.gz::https://git.macaw.me/blue/lmdbal/archive/0.2.0.tar.gz
+ sha256sums = 9f676ecaa64a5396a0b2fc29d0dd7cd16d374ccd7daf06d286b5c63074934fcd
+
+pkgname = lmdbal
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70176f2e48d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Yury Gubich <blue@macaw.me>
+pkgname=lmdbal
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="LMDB Abstraction Layer, qt5 version"
+arch=('i686' 'x86_64')
+url="https://git.macaw.me/blue/lmdbal"
+license=('GPL3')
+depends=( 'lmdb' 'qt5-base')
+makedepends=('cmake>=3.16')
+optdepends=()
+
+source=("$pkgname-$pkgver.tar.gz::https://git.macaw.me/blue/lmdbal/archive/$pkgver.tar.gz")
+sha256sums=('9f676ecaa64a5396a0b2fc29d0dd7cd16d374ccd7daf06d286b5c63074934fcd')
+build() {
+ cd "$srcdir/$pkgname"
+ cmake . -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D QT_VERSION_MAJOR=5
+ cmake --build .
+}
+package() {
+ cd "$srcdir/$pkgname"
+ DESTDIR="$pkgdir/" cmake --install .
+}