summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblue2023-10-15 14:22:29 +0000
committerblue2023-10-15 14:22:29 +0000
commitc3cc998b1840231829097ba79c152c835000b28b (patch)
treea48887553bbded967fb68be2a8d3543b1c84c365
parent105e4661d2df08dae534f1c34b0a6aa14c307310 (diff)
downloadaur-c3cc998b1840231829097ba79c152c835000b28b.tar.gz
### New Features
- duplicates support (only for table) ### Improvements - some more documentation - more tests
-rwxr-xr-x[-rw-r--r--].SRCINFO7
-rwxr-xr-x[-rw-r--r--]PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d885db06058e..0c7878f336ec 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = lmdbal
pkgdesc = LMDB Abstraction Layer, qt5 version
- pkgver = 0.4.0
+ pkgver = 0.5.0
pkgrel = 1
url = https://git.macaw.me/blue/lmdbal
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake>=3.16
+ makedepends = gcc
depends = lmdb
depends = qt5-base
- source = lmdbal-0.4.0.tar.gz::https://git.macaw.me/blue/lmdbal/archive/0.4.0.tar.gz
- sha256sums = 2356335c944eb9e1126cc83d6545fc0d378f18cd39fa749cca347d54327d5d35
+ source = lmdbal-0.5.0.tar.gz::https://git.macaw.me/blue/lmdbal/archive/0.5.0.tar.gz
+ sha256sums = bf3f8e433c9b92e579b373d5b99cdbbda5277aab83d3792768a28cfa9c5ae7e9
pkgname = lmdbal
diff --git a/PKGBUILD b/PKGBUILD
index 12767d8956ff..5eea3352e7eb 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Yury Gubich <blue@macaw.me>
pkgname=lmdbal
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="LMDB Abstraction Layer, qt5 version"
arch=('i686' 'x86_64')
url="https://git.macaw.me/blue/lmdbal"
license=('GPL3')
depends=( 'lmdb' 'qt5-base')
-makedepends=('cmake>=3.16')
+makedepends=('cmake>=3.16' 'gcc')
optdepends=()
-source=("$pkgname-$pkgver.tar.gz::https://git.macaw.me/blue/lmdbal/archive/$pkgver.tar.gz")
-sha256sums=('2356335c944eb9e1126cc83d6545fc0d378f18cd39fa749cca347d54327d5d35')
+source=("$pkgname-$pkgver.tar.gz::https://git.macaw.me/blue/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('bf3f8e433c9b92e579b373d5b99cdbbda5277aab83d3792768a28cfa9c5ae7e9')
build() {
cd "$srcdir/$pkgname"
cmake . -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D QT_VERSION_MAJOR=5