summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBleuzen2017-10-10 15:41:49 +0200
committerBleuzen2017-10-10 15:41:49 +0200
commitea43f7967b73348c2823b527862f80814720b617 (patch)
tree5ee2ee713ab7cbef1e612fb70ad649cd90175bab
downloadaur-ea43f7967b73348c2823b527862f80814720b617.tar.gz
first commit
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD42
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..189039261918
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = lmms-beta
+ pkgdesc = The Linux MultiMedia Studio.
+ pkgver = 1.2.0_rc4
+ pkgrel = 1
+ url = https://lmms.io/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = ladspa
+ makedepends = libxft
+ makedepends = freetype2
+ makedepends = fftw
+ makedepends = stk
+ makedepends = wine
+ depends = sdl
+ depends = glib2
+ depends = fluidsynth
+ depends = libpng
+ depends = libvorbis
+ depends = libxft
+ depends = libxinerama
+ depends = qt4
+ depends = sdl_sound
+ depends = libsamplerate
+ depends = shared-mime-info
+ depends = fltk
+ optdepends = wine: VST support (experimental)
+ optdepends = fftw: SpectrumAnalyzer plugin
+ optdepends = stk: STK instruments plugins
+ optdepends = pulseaudio: PulseAudio output
+ provides = lmms
+ provides = lmms-extras
+ conflicts = lmms
+ conflicts = lmms-extras
+ options = !makeflags
+ source = https://github.com/LMMS/lmms/archive/v1.2.0-rc4.tar.gz
+ md5sums = cd2d77dfe750b6e42de1ca68543aa7fe
+ makedepends_x86_64 = gcc-multilib
+
+pkgname = lmms-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b72380cd9dfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Bleuzen <supgesu at gmail dot com>
+
+pkgname=lmms-beta
+_basever=1.2.0
+_rc=rc4
+pkgver=${_basever}_${_rc}
+pkgrel=1
+pkgdesc='The Linux MultiMedia Studio.'
+arch=('x86_64')
+url='https://lmms.io/'
+license=('GPL')
+depends=('sdl' 'glib2' 'fluidsynth' 'libpng' 'libvorbis' 'libxft' 'libxinerama' 'qt4' 'sdl_sound'
+ 'libsamplerate' 'shared-mime-info' 'fltk')
+optdepends=('wine: VST support (experimental)'
+ 'fftw: SpectrumAnalyzer plugin'
+ 'stk: STK instruments plugins'
+ 'pulseaudio: PulseAudio output')
+makedepends=('cmake' 'ladspa' 'libxft' 'freetype2' 'fftw' 'stk' 'wine')
+makedepends_x86_64=('gcc-multilib')
+provides=('lmms' 'lmms-extras')
+conflicts=('lmms' 'lmms-extras')
+options=('!makeflags')
+source=("https://github.com/LMMS/lmms/archive/v${_basever}-${_rc}.tar.gz")
+md5sums=('cd2d77dfe750b6e42de1ca68543aa7fe')
+
+prepare() {
+ cd "${srcdir}/lmms-${_basever}-${_rc}"
+
+ sed -i 's|lib64|lib|g' cmake/modules/DetectMachine.cmake
+}
+
+build() {
+ cd "${srcdir}/lmms-${_basever}-${_rc}"
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -USE=vst
+ make -j4
+}
+
+package() {
+ cd "$srcdir/lmms-${_basever}-${_rc}"
+ make DESTDIR="${pkgdir}" install
+}