summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorslawomir2019-06-18 17:42:35 +0200
committerslawomir2019-06-18 17:42:35 +0200
commitd0ae4cf4f737686f6fbab997186f89e555b2b603 (patch)
tree5aa1866d08f41d92b2efca8ae6c4ec65077bdcb1
parent6b336bbb196a2aa4813464e90e26f507927ae935 (diff)
downloadaur-d0ae4cf4f737686f6fbab997186f89e555b2b603.tar.gz
Fixed a bug where bash auto-completion installs in wrong directory
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf5f508d77de..2931178ff9a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lmms-git
pkgdesc = The Linux MultiMedia Studio.
- pkgver = 1.2.0.rc7.r9.g5c362e51a
+ pkgver = 1.2.0.r3.g3ada5b8a1
pkgrel = 1
url = https://lmms.io
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index accf73a3a5f5..31595484104c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_name=lmms
pkgname=lmms-git
-pkgver=1.2.0.rc7.r9.g5c362e51a
+pkgver=1.2.0.r3.g3ada5b8a1
pkgrel=1
pkgdesc='The Linux MultiMedia Studio.'
arch=('x86_64')
@@ -42,10 +42,16 @@ prepare() {
# setting lib dir
sed -e 's|lib64|lib|g' -i cmake/modules/DetectMachine.cmake
# setting proper DESTDIR based install path for bash-completion
- sed -e 's/\(${BASHCOMP_USER\)/\\$DESTDIR\1/g' -i cmake/modules/BashCompletion.cmake
+ #sed -e 's/\(${BASHCOMP_USER\)/\\$DESTDIR\1/g' -i cmake/modules/BashCompletion.cmake
+ #above commented beacuse of variable duplication (cmake module already puts $DESTDIR in shellfile,so replacing ${BASHCOMP_USER_PATH} with $DESTDIR is reduntant)
+ sed -e 's/\(${BASHCOMP_USER\)/\1/g' -i cmake/modules/BashCompletion.cmake
}
build() {
+ #first we patch the generated destdir in shell
+ #echo "Patching dir for autocompletion."
+ #patch < fix_bash_completion_dir.patch
+ #echo "Done"
cd "${_name}/build"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DWANT_QT5=ON \