summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-07-12 13:04:03 +0100
committerFFY002018-07-12 13:04:03 +0100
commit63c7acb5b6177096c3a8c44d8401c70dffb81d84 (patch)
tree463ddbe40817ed9f3081c32a89bf86235466a38d
downloadaur-63c7acb5b6177096c3a8c44d8401c70dffb81d84.tar.gz
pkgbuild: initial release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
-rw-r--r--lms8suite.desktop11
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..649ebf59d4d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lms8suite-git
+ pkgdesc = Utilities for use with hardware based upon LMS8001 RFICs from Lime Microsystems.
+ pkgver = 18.06.0
+ pkgrel = 1
+ url = https://github.com/myriadrf/LMS8Suite
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = cmake
+ depends = wxgtk3
+ depends = opengl-driver
+ depends = libusb>=1.0
+ depends = soapysdr
+ provides = lms8suite
+ conflicts = lms8suite
+ source = git+https://github.com/myriadrf/LMS8Suite
+ source = lms8suite.desktop
+ sha256sums = SKIP
+ sha256sums = ee741f0659c55f11e266cea102549d6c154692d970886684cd8207450aaed6ca
+
+pkgname = lms8suite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed42fae3f5a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Filipe LaĆ­ns (FFY00) <filipe.lains@gmail.com>
+pkgname=lms8suite-git
+_pkgname=LMS8Suite
+pkgver=18.06.0
+pkgrel=1
+pkgdesc="Utilities for use with hardware based upon LMS8001 RFICs from Lime Microsystems."
+arch=(any)
+url="https://github.com/myriadrf/LMS8Suite"
+license=('Apache')
+depends=('wxgtk3' 'opengl-driver' 'libusb>=1.0' 'soapysdr')
+makedepends=('git' 'cmake')
+provides=('lms8suite')
+conflicts=('lms8suite')
+source=("git+$url"
+ 'lms8suite.desktop')
+sha256sums=('SKIP'
+ 'ee741f0659c55f11e266cea102549d6c154692d970886684cd8207450aaed6ca')
+
+prepare() {
+ # Fix build
+ sed -i "s|#include <mutex>|#include <mutex>\n#include <functional>|" "$srcdir"/$_pkgname/src/lms8001/lmsComms.h
+}
+
+build() {
+ mkdir -p "$srcdir"/$_pkgname/build
+ cd "$srcdir"/$_pkgname/build
+
+ cmake ../src \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ # Binary
+ install -Dm 775 "$srcdir"/$_pkgname/build/bin/lms8suite "$pkgdir"/usr/bin/lms8suite
+
+ # .desktop file
+ install -Dm 664 "$srcdir"/lms8suite.desktop "$pkgdir"/usr/share/applications/lms8suite.desktop
+
+ # .ini files
+ mkdir -p "$pkgdir"/usr/share/$_pkgname
+ cp -dr --no-preserve=ownership "$srcdir"/$_pkgname/ini/ "$pkgdir"/usr/share/$_pkgname/
+}
diff --git a/lms8suite.desktop b/lms8suite.desktop
new file mode 100644
index 000000000000..57d918e8deee
--- /dev/null
+++ b/lms8suite.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=LMS8Suite
+GenericName=LMS8Suite
+Comment=Utilities for use with hardware based upon LMS8001 RFICs from Lime Microsystems.
+Exec=lms8suite
+Icon=modem
+StartupNotify=true
+Type=Application
+Categories=Utility;Electronics;GTK;