summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2019-05-11 12:31:50 +1000
committerLuis Aranguren2019-05-11 12:31:50 +1000
commit0a7f81df55f3a13b41aa4f7a9d001c5b5158fc5b (patch)
treed49f32947a0c40e1d4ece0afaacc0c7e78877742
parent0b5f767b329e82d2baffc9c330f46d652397bc4d (diff)
downloadaur-0a7f81df55f3a13b41aa4f7a9d001c5b5158fc5b.tar.gz
update pkgver to 0.6.1.beta.r12.gf8c824fb and fixed changed folders
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f4e54c33e89..3360f6abdf58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lnd-git
pkgdesc = The Lightning Network Daemon, for secure off-chain bitcoin transactions.
- pkgver = v0.6.beta.rc2.r0.g3a19afe4
+ pkgver = v0.6.1.beta.r12.gf8c824fb
pkgrel = 1
url = https://github.com/lightningnetwork/lnd
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = lnd-git
depends = glibc
provides = lnd
provides = lnd-cli
+ conflicts = lnd
source = lnd-git::git+https://github.com/lightningnetwork/lnd.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6842e541614d..d7d54fbf9a2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Upstream: https://github.com/lightningnetwork/lnd
pkgname=('lnd-git')
-pkgver=v0.6.beta.rc2.r0.g3a19afe4
+pkgver=v0.6.1.beta.r12.gf8c824fb
pkgrel=1
pkgdesc='The Lightning Network Daemon, for secure off-chain bitcoin transactions.'
arch=('x86_64')
@@ -14,7 +14,7 @@ license=('MIT')
depends=('glibc')
makedepends=('git' 'go-pie' 'fakeroot')
provides=('lnd' 'lnd-cli')
-conflicts=()
+conflicts=('lnd')
source=("$pkgname::git+https://github.com/lightningnetwork/lnd.git")
md5sums=('SKIP')
@@ -25,14 +25,15 @@ pkgver() {
build() {
cd $pkgname
+ cd cmd/lnd
go build -buildmode=pie -ldflags -extldflags=-Wl,-z,now,-z,relro .
- cd cmd/lncli
+ cd ../lncli
go build -buildmode=pie -ldflags -extldflags=-Wl,-z,now,-z,relro .
}
package() {
cd $pkgname
- install -Dm 755 "lnd" -t "$pkgdir/usr/bin";
+ install -Dm 755 "cmd/lnd/lnd" -t "$pkgdir/usr/bin";
install -Dm 755 "cmd/lncli/lncli" -t "$pkgdir/usr/bin";
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}