summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2018-12-12 21:06:23 +1100
committerLuis Aranguren2018-12-12 21:06:23 +1100
commit4baef40a7133b23bbc72aadc76b90fa9071f2aa9 (patch)
treeb20bec6eeec38c8bdf154e2903b7e5025f49b028
parent1dc264d1768dab71984d359f0faa220e25a21225 (diff)
downloadaur-4baef40a7133b23bbc72aadc76b90fa9071f2aa9.tar.gz
update pkgver to 0.5.1.beta and rework of PKGBUILD for Go 1.11
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD28
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71a0d59092ef..e11ba8a5f857 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = lnd-git
pkgdesc = The Lightning Network Daemon, for secure off-chain bitcoin transactions.
- pkgver = 0.5.1.beta.rc3
+ pkgver = 0.5.1.beta.160.gdc7c5974
pkgrel = 1
url = https://github.com/lightningnetwork/lnd
arch = x86_64
license = MIT
makedepends = git
- makedepends = dep
makedepends = go
makedepends = fakeroot
depends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index e21a30ea9243..95360d11ca6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
# Upstream: https://github.com/lightningnetwork/lnd
pkgname=('lnd-git')
-pkgver=0.5.1.beta.rc3
+pkgver=0.5.1.beta.160.gdc7c5974
pkgrel=1
pkgdesc='The Lightning Network Daemon, for secure off-chain bitcoin transactions.'
arch=('x86_64')
url='https://github.com/lightningnetwork/lnd'
license=('MIT')
depends=('glibc')
-makedepends=('git' 'dep' 'go' 'fakeroot')
+makedepends=('git' 'go' 'fakeroot')
provides=('lnd' 'lnd-cli')
conflicts=()
source=("$pkgname::git+https://github.com/lightningnetwork/lnd.git")
@@ -23,21 +23,17 @@ pkgver() {
git describe --tags | sed 's/^v//;s/-/./g'
}
-prepare() {
- export GOPATH="$srcdir"
- rm -fr "$srcdir/src"
- git clone "$srcdir/$pkgname" "$GOPATH/src/github.com/lightningnetwork/lnd"
+build() {
+ #To do : Add RELRO and PIE
+ cd $pkgname
+ go build .
+ cd cmd/lncli
+ go build .
}
package() {
- export GOPATH="$srcdir"
- cd "$GOPATH/src/github.com/lightningnetwork/lnd"
- dep ensure
- go install . ./cmd/...
-
- for _bin in lnd lncli; do
- install -Dm 755 "$srcdir/bin/$_bin" -t "$pkgdir/usr/bin";
- done
-
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $pkgname
+ install -Dm 755 "lnd" -t "$pkgdir/usr/bin";
+ install -Dm 755 "cmd/lncli/lncli" -t "$pkgdir/usr/bin";
+ install -D -m644 LICENSE "$pkgdir/LICENSE"
}