summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2020-06-09 14:12:00 +1000
committerLuis Aranguren2020-06-09 14:12:00 +1000
commit5072ddc38f4bf4770d7b5e2c75ff4b6e794897e0 (patch)
tree02ec45b21bda89360ee06d329f86ffc9255e0bce
parent783e254c716c4c6378f7ba4a4f68eed284f959b8 (diff)
downloadaur-5072ddc38f4bf4770d7b5e2c75ff4b6e794897e0.tar.gz
update pkgver to 0.10.1.beta.r9783.38b8e54ba, updated go-pie->go from updated guidelines in https://wiki.archlinux.org/index.php/Go_package_guidelines#Building, fixed recurrent tag problem
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bad78a75f71b..b69206e984b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = lnd-git
pkgdesc = The Lightning Network Daemon, for secure off-chain bitcoin transactions.
- pkgver = v0.10.0.beta.rc2.r0.geec3799d
+ pkgver = v0.10.1.beta.r9783.38b8e54ba
pkgrel = 1
url = https://github.com/lightningnetwork/lnd
arch = x86_64
license = MIT
makedepends = git
- makedepends = go-pie
+ makedepends = go
makedepends = fakeroot
depends = glibc
provides = lnd
diff --git a/PKGBUILD b/PKGBUILD
index 00c994f53f49..be3cb7b09c54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
# Upstream: https://github.com/lightningnetwork/lnd
pkgname=('lnd-git')
-pkgver=v0.10.0.beta.rc2.r0.geec3799d
+pkgver=v0.10.1.beta.r9783.38b8e54ba
pkgrel=1
pkgdesc='The Lightning Network Daemon, for secure off-chain bitcoin transactions.'
arch=('x86_64')
url='https://github.com/lightningnetwork/lnd'
license=('MIT')
depends=('glibc')
-makedepends=('git' 'go-pie' 'fakeroot')
+makedepends=('git' 'go' 'fakeroot')
provides=('lnd' 'lnd-cli')
conflicts=('lnd')
source=("$pkgname::git+https://github.com/lightningnetwork/lnd.git")
@@ -20,7 +20,9 @@ md5sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag --list --sort=taggerdate | tail -n1 | sed 's/\([^-]*-g\)/r\1/;s/-/./g')
+ printf $_tag;
+ printf ".r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {