summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 14:47:34 +0200
committerAlexander F Rødseth2015-06-10 14:47:34 +0200
commit6a3c84f706c8c6772290d2d89e462d1a3b603a4d (patch)
treeecb54c81c83cb0fb71f88aa813fe49941eef7e4f
downloadaur-6a3c84f706c8c6772290d2d89e462d1a3b603a4d.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
-rw-r--r--load81.install14
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0ef721a1c4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = load81-git
+ pkgdesc = C64 like environment for Lua and SDL
+ pkgver = 20120321
+ pkgrel = 1
+ url = https://github.com/antirez/load81
+ install = load81.install
+ arch = x86_64
+ arch = i686
+ license = BSD
+ depends = lua
+ depends = sdl
+ depends = sdl_gfx
+
+pkgname = load81-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c0028f1fb28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=load81-git
+pkgver=20120321
+pkgrel=1
+pkgdesc="C64 like environment for Lua and SDL"
+arch=('x86_64' 'i686')
+url="https://github.com/antirez/load81"
+license=('BSD')
+depends=('lua' 'sdl' 'sdl_gfx')
+install=load81.install
+_gitroot="git://github.com/antirez/load81"
+_gitname="load81"
+
+build() {
+ cd "$srcdir"
+
+ msg "Connecting to the git repository..."
+ if [ -d "$srcdir/$_gitname" ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ cd "$srcdir"
+ rm -rf $_gitname-build
+ git clone $_gitname $_gitname-build
+ cd "$_gitname-build"
+
+ make
+}
+
+package() {
+ cd "$_gitname-build"
+
+ install -Dm755 load81 "$pkgdir/usr/bin/load81"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/load81.install b/load81.install
new file mode 100644
index 000000000000..ef816a666684
--- /dev/null
+++ b/load81.install
@@ -0,0 +1,14 @@
+post_upgrade() {
+ gtk-update-icon-cache -q -f -t /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_install() {
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}
+
+# vim:set ts=2 sw=2 et: