summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShengyu Zhang2016-10-30 19:22:42 +0800
committerShengyu Zhang2016-10-30 19:22:42 +0800
commit64d63190839591578d2eed08d0217d8fb7cd798d (patch)
tree607778aabdc09b1e991b12cfae991c70b4ef058b
downloadaur-64d63190839591578d2eed08d0217d8fb7cd798d.tar.gz
Import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1bf810cff11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Oct 30 11:22:34 UTC 2016
+pkgbase = loc
+ pkgdesc = Count lines of code quickly
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/cgag/loc
+ arch = x86_64
+ arch = i386
+ license = MIT
+ makedepends = cargo-nightly
+ makedepends = git
+ source = https://github.com/cgag/loc/archive/v0.3.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = loc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e2a103d6942
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: SY.Zhang <lastavengers@archlinuxcn.org>
+pkgname=loc
+pkgver=0.3.2
+pkgrel=1
+pkgdesc='Count lines of code quickly'
+arch=('x86_64' 'i386')
+url='https://github.com/cgag/loc'
+license=('MIT')
+makedepends=('cargo-nightly' 'git')
+source=("https://github.com/cgag/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build () {
+ cd ${pkgname}-${pkgver}
+ cargo build --release
+}
+
+package () {
+ cd ${pkgname}-${pkgver}/target/release
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+}