aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Moser2021-01-16 18:07:42 +0100
committerFlorian Moser2021-01-16 18:07:42 +0100
commit53f3bbe33e1cbb381814790f8e70974a2d6af928 (patch)
treeb85591686c1031a332cd9c8eafd1d11402c4c92f
downloadaur-53f3bbe33e1cbb381814790f8e70974a2d6af928.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--.travis.yml18
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD17
-rw-r--r--README.md16
-rwxr-xr-xupdate.sh14
7 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0430cc028b48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = local-php-security-checker
+ pkgdesc = PHP security vulnerabilities checker.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/fabpot/local-php-security-checker
+ arch = x86_64
+ license = GNU Affero General Public License v3.0
+ source = local-php-security-checker-1.0.0::https://github.com/fabpot/local-php-security-checker/releases/download/v1.0.0/local-php-security-checker_1.0.0_linux_amd64
+ sha256sums = e5b12488ca78bc07c149e9352278bf10667b88a8461caac10154f9a6f5476369
+
+pkgname = local-php-security-checker
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d250d8a59b31
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+local-php-security-checker*
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..1ad4609b9c3b
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,18 @@
+sudo: required
+
+services:
+ - docker
+
+archlinux:
+ packages:
+ - namcap
+ script:
+ - "PKGEXT='.pkg.tar' makepkg -si --noconfirm"
+ - "namcap PKGBUILD"
+ - "namcap symfony*.pkg*"
+
+script:
+ - "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
+
+notifications:
+ email: false \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1cc5efdd4d5d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Florian Moser
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9801e6618034
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Florian Moser <arch@famoser.ch>
+
+pkgname=local-php-security-checker
+pkgrel=1
+pkgver=1.0.0
+pkgdesc="PHP security vulnerabilities checker."
+url="https://github.com/fabpot/local-php-security-checker"
+arch=('x86_64')
+license=('GNU Affero General Public License v3.0')
+source=(
+ "$pkgname-$pkgver::https://github.com/fabpot/local-php-security-checker/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_amd64"
+)
+sha256sums=('e5b12488ca78bc07c149e9352278bf10667b88a8461caac10154f9a6f5476369')
+
+package() {
+ install -D -m 755 "${srcdir}/$pkgname-$pkgver" "${pkgdir}/usr/bin/local-php-security-checker"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..61eb1003103e
--- /dev/null
+++ b/README.md
@@ -0,0 +1,16 @@
+# Symfony CLI AUR Package
+[![Build Status](https://travis-ci.com/famoser/symfony-cli-aur.svg?branch=master)](https://travis-ci.com/famoser/symfony-cli-aur)
+
+## Update package
+
+0. Get newest version from https://github.com/symfony/cli/releases
+1. Update package version in PKGBUILD
+2. Execute `update.sh`
+
+or
+
+3. Generate new checksums with `updpkgsums`
+4. Test install `makepkg -si`
+5. Update .SRCINFO `makepkg --printsrcinfo > .SRCINFO`
+6. `git remote add arch ssh://aur@aur.archlinux.org/symfony-cli.git`
+7. `git push arch`
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..67d61b71e630
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,14 @@
+# /bin/bash
+set -e
+rm -rf src
+rm -rf pkg
+rm -rf local-php-security-checker*
+updpkgsums
+makepkg -si
+makepkg --printsrcinfo > .SRCINFO
+set +e
+git add .
+git commit -m "update package"
+git push
+git remote add arch ssh://aur@aur.archlinux.org/local-php-security-checker.git
+git push arch \ No newline at end of file