summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYo'av Moshe2023-04-10 21:15:40 +0200
committerYo'av Moshe2023-04-10 21:15:40 +0200
commitd26d9e271c6f8f3f92ce6bbe48fa4879400c14df (patch)
tree9c6a1bbe0d693a4f4337c6143fbd089cc33100fd
downloadaur-d26d9e271c6f8f3f92ce6bbe48fa4879400c14df.tar.gz
first version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd747c419a7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = localcommand
+ pkgdesc = Run local commands directly from the web
+ pkgver = 0.1.1
+ pkgrel = 0
+ url = https://github.com/bjesus/localcommand
+ arch = x86_64
+ license = MIT
+ optdepends = zenity
+ source = source.tar.zxvf::https://github.com/bjesus/localcommand/releases/download/0.1.1/localcommand-0.1.1-linux-amd64.tar.gz
+ source = https://raw.githubusercontent.com/bjesus/localcommand/main/localcommand.desktop
+ sha512sums = bf9f95abcc6ccfe7b203454b481cc26e6f1880953ff95765ccda32302ecce7f0ddf6d32453f445a617d9aa3476f2ea9deb1bb09d9d9d697029cad18794f90e7c
+ sha512sums = 1b5a7562e7f3855d4f10f2b4bdce19d2950e1d230819c912bf79a39d74388e115f25fda060c44959924b9f546e98ba6ef8e0c536b5d87a6ac33a694d2f48698a
+
+pkgname = localcommand
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc1d46dab299
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Yo'av Moshe <archlinux@yoavmoshe.com>
+pkgname=localcommand
+_pkgname=localcommand
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="Run local commands directly from the web"
+url="https://github.com/bjesus/localcommand"
+arch=("any")
+license=("MIT")
+optdepends=('zenity')
+source=("source.tar.gz::https://github.com/bjesus/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha512sums=("e1946528088e101bb085654a733ed0dcc64235a725bb8744888e02b3ff53418eb7f49fd51599d17a6f155ac87825fa3b1f74a1f9cbbece656e4415b083f58f61")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ GO111MODULE=on go build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver" || exit
+ install -Dm0755 -t "$pkgdir/usr/bin/" "$pkgname"
+ install -Dm0744 -t "$pkgdir/usr/share/applications" "$pkgname.desktop"
+}
+