summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonhnny Weslley2015-07-04 15:06:15 -0300
committerJonhnny Weslley2015-07-04 15:07:47 -0300
commit5c0a54d288534cf1888213161d085d74b7b4f0a8 (patch)
treeb16cf30fc514863b2a6c23dbf372877c3bda0fa1
downloadaur-5c0a54d288534cf1888213161d085d74b7b4f0a8.tar.gz
initial import: 0.1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
-rw-r--r--localdns.install5
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1584615e495f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = localdns
+ pkgdesc = A DNS for local development
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/jweslley/localdns
+ install = localdns.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = glibc
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/jweslley/localdns/archive/v0.1.0.tar.gz
+ md5sums = e040cd45d1ca14d554e1be1d0a39d2ed
+
+pkgname = localdns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31a9bd716581
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jonhnny Weslley <jw@jonhnnyweslley.net>
+pkgname=localdns
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A DNS for local development"
+arch=('i686' 'x86_64')
+url="https://github.com/jweslley/$pkgname"
+license=('MIT')
+depends=('glibc')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+install=$pkgname.install
+source=("https://github.com/jweslley/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('e040cd45d1ca14d554e1be1d0a39d2ed')
+
+build() {
+ cd "$pkgname-$pkgver"
+ export GOPATH="$srcdir"
+ export GOBIN="."
+
+ go get ./...
+ go build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 ext/linux/localdns.service "$pkgdir"/usr/lib/systemd/system/localdns.service
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/localdns.install b/localdns.install
new file mode 100644
index 000000000000..2a4652313bdd
--- /dev/null
+++ b/localdns.install
@@ -0,0 +1,5 @@
+
+post_install() {
+ echo -e "\nAppend the line above to your '/etc/resolv.conf' file:"
+ echo -e "\n nameserver 127.0.0.1\n"
+}