summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWojciech W2021-02-27 16:21:03 +0000
committerWojciech W2021-02-27 16:21:03 +0000
commit05cbe370b53336f4573af0611f32362c8f56378d (patch)
tree9709a8a7095490779931931a95685673bb003252
parent0fdd713d49cc433059b553f94d3732f01a4fcb89 (diff)
downloadaur-05cbe370b53336f4573af0611f32362c8f56378d.tar.gz
libcrafter as dependency
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8006388b985e..eb995520f601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = localdns-git
pkgdesc = With this package the user is able to define a wrapper around DNS resolution with which one can define some fake dns adresses that will be mapped to a specific device on a local network identified by a mac address.
- pkgver = 0.2
- pkgrel = 9
+ pkgver = 0.2.1
+ pkgrel = 1
url = https://github.com/TETRX/local-dns-dump
arch = x86_64
license = GPL
@@ -12,6 +12,7 @@ pkgbase = localdns-git
depends = python>=3
depends = python-dnslib
depends = python-hosts>=1.0
+ depends = libcrafter-git
source = git+https://github.com/TETRX/local-dns-dump#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 390510cdab61..888f415d4c50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer:
pkgname=localdns-git
-pkgver=0.2
-pkgrel=9
+pkgver=0.2.1
+pkgrel=1
pkgdesc="With this package the user is able to define a wrapper around DNS resolution with which one can define some fake dns adresses that will be mapped to a specific device on a local network identified by a mac address."
arch=(x86_64)
url="https://github.com/TETRX/local-dns-dump"
license=('GPL')
-depends=('python>=3' 'python-dnslib' 'python-hosts>=1.0')
+depends=('python>=3' 'python-dnslib' 'python-hosts>=1.0' 'libcrafter-git')
makedepends=('git' 'make' 'gcc>=10' 'autoconf')
source=("git+$url#branch=master")
md5sums=('SKIP')
@@ -14,14 +14,10 @@ md5sums=('SKIP')
build() {
cd "local-dns-dump"
- git submodule init
- git submodule update
-
+ make get_ip
}
package() {
cd "local-dns-dump"
- make DESTDIR="$pkgdir" libcrafter
- make get_ip
make DESTDIR="$pkgdir" install
}