summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWojciech W2021-02-13 16:45:07 +0000
committerWojciech W2021-02-13 16:45:07 +0000
commitb1603f2303e183f0b685193cd58e66018cc72b8a (patch)
treeabcfb756f112faffd44d466d3a1bf591b2200063
downloadaur-b1603f2303e183f0b685193cd58e66018cc72b8a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7e3e604d8ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = localdns-git
+ pkgdesc = With this package the user is able to define a wrapper around DNS resolution with which one can define some fake dns adresses that will be mapped to a specific device on a local network identified by a mac address.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/TETRX/local-dns-dump
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = make
+ makedepends = gcc>=10
+ depends = python>=3
+ depends = python-dnslib
+ source = git+https://github.com/TETRX/local-dns-dump#branch=master
+ md5sums = SKIP
+
+pkgname = localdns-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99327f8bcfdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer:
+pkgname=localdns-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="With this package the user is able to define a wrapper around DNS resolution with which one can define some fake dns adresses that will be mapped to a specific device on a local network identified by a mac address."
+arch=(x86_64)
+url="https://github.com/TETRX/local-dns-dump"
+license=('GPL')
+depends=('python>=3' 'python-dnslib')
+makedepends=('git' 'make' 'gcc>=10')
+source=("git+$url#branch=master")
+md5sums=('SKIP')
+
+
+build() {
+ cd "local-dns-dump"
+ make local_dns
+}
+
+package() {
+ cd "local-dns-dump"
+ make DESTDIR="$pkgdir" install
+}