summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Bero2016-03-13 17:57:57 -0500
committerChristopher Bero2016-03-13 17:57:57 -0500
commitdf06771a05497f540b930540b2f50045c8da601b (patch)
tree0f3eef288b4616b79e16d65edff71b780e1008ac
downloadaur-df06771a05497f540b930540b2f50045c8da601b.tar.gz
initial pkgbuild
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e13c8679ecb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 22:57:47 UTC 2016
+pkgbase = localplot-git
+ pkgdesc = HPGL Plotting software to drive a serial vinyl cutter.
+ pkgver = 23.5535df2
+ pkgrel = 1
+ url = https://github.com/makerslocal/localplot
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-base
+ depends = qt5-serialport
+ source = localplot::git+https://github.com/makerslocal/localplot.git
+ sha256sums = SKIP
+
+pkgname = localplot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fab7d2d9b1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christopher Bero <bigbero@gmail.com>
+pkgname=localplot-git
+_pkgname=localplot
+pkgver=23.5535df2
+pkgrel=1
+pkgdesc="HPGL Plotting software to drive a serial vinyl cutter."
+arch=('i686' 'x86_64')
+url="https://github.com/makerslocal/localplot"
+license=('GPL3')
+#group=('')
+depends=('qt5-serialport')
+makedepends=('git' 'qt5-base')
+#optdepends=('')
+#noextract=('')
+source=(${_pkgname}::"git+https://github.com/makerslocal/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+#prepare() {
+#}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ /usr/lib/qt/bin/qmake -spec linux-g++ CONFIG+=release -o Makefile localplot.pro
+ make
+}
+
+package() {
+ install -D "$srcdir/localplot/localplot" "$pkgdir/usr/bin/localplot"
+ install -D "$srcdir/localplot/localplot.desktop" "$pkgdir/usr/share/applications/localplot.desktop"
+}