summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSmail Barkouch2021-06-13 13:35:24 -0400
committerSmail Barkouch2021-06-13 13:35:24 -0400
commit2f1bab812a4bf719b6f699246e611fc0ecf10437 (patch)
tree6696d36c3ab6a2b710eec1ce4dd81d02392f282f
parentdc785463df81aace98224386ca5b7b8302a9f5a2 (diff)
downloadaur-2f1bab812a4bf719b6f699246e611fc0ecf10437.tar.gz
added spell checking dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d14fca3d52f..638ec1b89374 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,6 +18,12 @@ pkgbase = lockbook-desktop
depends = atk
depends = gobject-introspection-runtime
depends = libepoxy
+ depends = gspell
+ optdepends = aspell-en: english dictionary for spellcheck
+ optdepends = aspell-es: spanish dictionary for spellcheck
+ optdepends = aspell-fr: french dictionary for spellcheck
+ optdepends = aspell-de: german dictionary for spellcheck
+ optdepends = aspell-ru: russian dictionary for spellcheck
provides = lockbook-desktop
conflicts = lockbook-desktop
source = git+https://github.com/lockbook/aur-lockbook-desktop.git
diff --git a/PKGBUILD b/PKGBUILD
index 449605cc5673..39729c1a0079 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,14 @@ url="https://github.com/lockbook/lockbook"
pkgdesc="A secure, private, minimal, cross-platform document editor."
license=('BSD-3-Clause')
makedepends=('rust' 'cargo' 'git')
-depends=('gtksourceview3' 'gtk3' 'pango' 'glib2' 'gdk-pixbuf2' 'atk' 'gobject-introspection-runtime' 'libepoxy')
+depends=('gtksourceview3' 'gtk3' 'pango' 'glib2' 'gdk-pixbuf2' 'atk' 'gobject-introspection-runtime' 'libepoxy' 'gspell')
+optdepends=(
+ 'aspell-en: english dictionary for spellcheck'
+ 'aspell-es: spanish dictionary for spellcheck'
+ 'aspell-fr: french dictionary for spellcheck'
+ 'aspell-de: german dictionary for spellcheck'
+ 'aspell-ru: russian dictionary for spellcheck'
+)
provides=('lockbook-desktop')
conflicts=('lockbook-desktop')
source=("git+https://github.com/lockbook/aur-lockbook-desktop.git" "git+https://github.com/lockbook/lockbook.git")
@@ -25,10 +32,8 @@ build(){
cargo build --release --locked
}
-package() {
- mv "$srcdir/lockbook/clients/linux/target/release/lockbook" "$srcdir/lockbook/clients/linux/target/release/lockbook-desktop"
-
- install -D -m755 "$srcdir/lockbook/clients/linux/target/release/lockbook-desktop" "$pkgdir/usr/bin/lockbook-desktop"
+package() {
+ install -D -m755 "$srcdir/lockbook/target/release/lockbook-desktop" "$pkgdir/usr/bin/lockbook-desktop"
install -D -m644 "$srcdir/lockbook/graphics/SVGs/dark-1.svg" "$pkgdir/usr/share/pixmaps/dark-1.svg"
install -D -m644 "$srcdir/aur-lockbook-desktop/lockbook-desktop.desktop" "$pkgdir/usr/share/applications/lockbook-desktop.desktop"
}