summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParth2021-04-04 18:30:43 -0400
committerParth2021-04-04 18:30:43 -0400
commit62c2a56e63361ffbdbd68d035f4dd3684f951fdf (patch)
tree12448194988ba5ac9994f8d53d09e610c26d9464
downloadaur-62c2a56e63361ffbdbd68d035f4dd3684f951fdf.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD35
-rw-r--r--lockbook.desktop9
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..450cbe152c7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lockbook-desktop
+ pkgdesc = A secure, private, minimal, cross-platform document editor.
+ pkgver = 0.2.9
+ pkgrel = 2
+ url = https://github.com/lockbook/lockbook
+ arch = x86_64
+ arch = i686
+ groups = lockbook
+ license = BSD-3-Clause
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ depends = gtksourceview3
+ depends = gtk3
+ depends = pango
+ depends = glib2
+ depends = gdk-pixbuf2
+ depends = atk
+ depends = gobject-introspection-runtime
+ depends = libepoxy
+ provides = lockbook-desktop
+ conflicts = lockbook-desktop
+ source = git+https://github.com/lockbook/aur-lockbook-desktop.git
+ source = git+https://github.com/lockbook/lockbook.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = lockbook-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7dc76f7b07c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname='lockbook-desktop'
+_pkgname="lockbook-desktop"
+pkgver=0.2.9
+pkgrel=2
+arch=('x86_64' 'i686')
+url="https://github.com/lockbook/lockbook"
+pkgdesc="A secure, private, minimal, cross-platform document editor."
+license=('BSD-3-Clause')
+makedepends=('rust' 'cargo' 'git')
+depends=('gtksourceview3' 'gtk3' 'pango' 'glib2' 'gdk-pixbuf2' 'atk' 'gobject-introspection-runtime' 'libepoxy')
+provides=('lockbook-desktop')
+conflicts=('lockbook-desktop')
+source=("git+https://github.com/lockbook/aur-lockbook-desktop.git" "git+https://github.com/lockbook/lockbook.git")
+sha256sums=('SKIP' 'SKIP')
+groups=('lockbook')
+
+pkgver() {
+ cd $srcdir/lockbook/clients/linux
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1)"
+}
+
+build(){
+ echo $_pkgname
+ cd $srcdir/lockbook/clients/linux
+ cargo build --release --locked
+}
+
+package() {
+ mv "$srcdir/lockbook/clients/linux/target/release/lockbook" "$srcdir/lockbook/clients/linux/target/release/lockbook-desktop"
+
+ install -D -m755 "$srcdir/lockbook/clients/linux/target/release/lockbook-desktop" "$pkgdir/usr/bin/lockbook-desktop"
+ install -D -m644 "$srcdir/lockbook/graphics/SVGs/dark-1.svg" "$pkgdir/usr/share/pixmaps/dark-1.svg"
+ install -D -m644 "$srcdir/aur-lockbook-desktop/lockbook.desktop" "$pkgdir/usr/share/applications/lockbook.desktop"
+}
+
diff --git a/lockbook.desktop b/lockbook.desktop
new file mode 100644
index 000000000000..f2a17808ded1
--- /dev/null
+++ b/lockbook.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Comment=A secure, private, minimal, cross-platform document editor.
+Terminal=false
+Exec=/usr/bin/lockbook-gui
+Name=Lockbook
+Icon=dark-1.svg \ No newline at end of file