summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2013-12-13 15:58:58 +0000
committerBalló György2013-12-13 15:58:58 +0000
commit3016282bea050c6b89ca131d25bf798616a87e0b (patch)
treea11005ec5214c0300e0f437d1b6ef0ea815e2022
parent618c67820c7657ec0da1e9f8474d13b5cff7b304 (diff)
downloadaur-3016282bea050c6b89ca131d25bf798616a87e0b.tar.gz
Remove static lib, fix build with gcc 4.7
-rw-r--r--PKGBUILD13
-rw-r--r--gcc-4.7.patch18
2 files changed, 26 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d1dab1af8fa..f6aa8195f9af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,32 @@
pkgname=lockdev
pkgver=1.0.3_1.5
_pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc='Run-time shared library for locking devices, using _both_ FSSTND and SVr4 methods.'
url='http://packages.qa.debian.org/l/lockdev.html'
license=("GPL")
arch=('i686' 'x86_64')
+depends=('glibc')
source=("http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${_pkgver}.orig.tar.gz"
"http://ftp.debian.org/debian/pool/main/l/${pkgname}/${pkgname}_${pkgver/_/-}.diff.gz"
- 'build.patch')
+ 'build.patch'
+ 'gcc-4.7.patch')
md5sums=('64b9c1b87b125fc348e892e24625524a'
'c4e8a5a2e46b76b48339c232b358f579'
- '2db93cadf6670ddcd01de4bfc22a35e1')
+ '2db93cadf6670ddcd01de4bfc22a35e1'
+ 'e16faebfa2d162d40830ef6f2700b7ba')
prepare() {
cd "${pkgname}-${_pkgver}"
patch -p1 -i "../${pkgname}_${pkgver/_/-}.diff"
sed -i "s|CFLAGS = -g|CFLAGS = -g -fPIC|" Makefile
patch -p1 -i ../build.patch # FS#33280
+ patch -p1 -i ../gcc-4.7.patch # FS#34457
}
build() {
cd "${pkgname}-${_pkgver}"
- make shared CFLAGS="${CFLAGS} -D_PATH_LOCK=\\\"/run/lock/lockdev\\\" -fPIC"
- make static CFLAGS="${CFLAGS} -D_PATH_LOCK=\\\"/run/lock/lockdev\\\" -fPIC"
+ make CFLAGS="${CFLAGS} -D_PATH_LOCK=\\\"/run/lock/lockdev\\\" -fPIC"
}
package() {
diff --git a/gcc-4.7.patch b/gcc-4.7.patch
new file mode 100644
index 000000000000..3b11e0b92b7d
--- /dev/null
+++ b/gcc-4.7.patch
@@ -0,0 +1,18 @@
+diff -Naur lockdev-1.0.3.orig/src/ttylock.h lockdev-1.0.3/src/ttylock.h
+--- lockdev-1.0.3.orig/src/ttylock.h 2013-12-13 15:34:52.195877321 +0000
++++ lockdev-1.0.3/src/ttylock.h 2013-12-13 15:38:16.131190480 +0000
+@@ -36,10 +36,10 @@
+
+ /* API of the library */
+
+-int ttylock (char * devname);
+-int ttywait (char * devname);
+-int ttyunlock (char * devname);
+-int ttylocked (char * devname);
++static inline int ttylock (char * devname);
++static inline int ttywait (char * devname);
++static inline int ttyunlock (char * devname);
++static inline int ttylocked (char * devname);
+
+
+ static inline int