summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSofiane Hamlaoui2020-09-16 21:45:21 +0200
committerSofiane Hamlaoui2020-09-16 21:45:21 +0200
commit7d28e3024688771d80b6b63999318c4ff63bed90 (patch)
tree1bb992d0ca3690a8732fee699e1f1c8023cc8f3f
downloadaur-7d28e3024688771d80b6b63999318c4ff63bed90.tar.gz
Fixing some issues
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD32
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4b2037d0b94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = lockdoor-git
+ pkgdesc = A penetration testing framework with cyber security resources
+ pkgver = 2.2.4
+ pkgrel = 1
+ url = http://github.com/SofianeHamlaoui/Lockdoor-Framework
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-pip
+ depends = python-requests
+ depends = python2
+ depends = python2-pip
+ depends = ruby
+ depends = php
+ depends = git
+ depends = wget
+ depends = netcat
+ depends = subversion
+ depends = jre-openjdk
+ depends = linux-headers
+ depends = rsync
+ provides = lockdoor-framework
+ conflicts = lockdoor-framework
+ options = !strip
+ source = lockdoor-framework::git+https://github.com/Lockdoor-Framework/Lockdoor-Framework
+ sha256sums = SKIP
+
+pkgname = lockdoor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61de78cd7312
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sofiane Hamlaoui <s0fianehaml40u1 at gmail dot com>
+
+pkgname=lockdoor-git
+_pkgname=lockdoor-framework
+pkgver=2.2.4
+pkgrel=1
+pkgdesc="A penetration testing framework with cyber security resources"
+url="http://github.com/SofianeHamlaoui/Lockdoor-Framework"
+arch=('any')
+license=('GPL3')
+depends=('python' 'python-pip' 'python-requests' 'python2' 'python2-pip' 'ruby' 'php' 'git' 'wget' 'netcat' 'subversion' 'jre-openjdk' 'linux-headers' 'rsync')
+optdepends=()
+optdepends=()
+makedepends=('git')
+provides=('lockdoor-framework')
+options=(!strip)
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Lockdoor-Framework/Lockdoor-Framework")
+sha256sums=(SKIP)
+
+pkgver() {
+ ver=$(curl -s -L https://raw.githubusercontent.com/SofianeHamlaoui/Lockdoor-Framework/master/VERSION)
+ printf "$ver"
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}/lockdoor" "${pkgdir}/usr/bin/lockdoor"
+ mkdir -p ${pkgdir}/usr/bin/lockdoors
+ rsync -a "${srcdir}/${_pkgname}/lockdoors" "${pkgdir}/usr/bin/"
+ mkdir -p ${pkgdir}/opt/sofiane/
+ rsync -a "${srcdir}/${_pkgname}/pentest" "${pkgdir}/opt/sofiane/"
+}