summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Tseng2017-11-12 02:45:20 -0800
committerPeter Tseng2017-11-12 02:49:08 -0800
commitabd63ad2b51a4afa7d169e334c5f33ebf1e14228 (patch)
tree29443258656788b8094186c82f3a3ea437861c8c
parent2a5bdea52c18ef7c4609019c090397eb63018724 (diff)
downloadaur-abd63ad2b51a4afa7d169e334c5f33ebf1e14228.tar.gz
pkgrel 7: No dumb, allegro -> allegro4
dumb doesn't provide the files we need (aldumb.h, libaldumb.so) anymore and I could not determine a way to make this work. However, everything seems to work just fine without it.
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 221c742a21f1..52dc47995b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=lockjaw
pkgver=046
-pkgrel=6
+pkgrel=7
pkgdesc="Free and highly customizable implementation of Tetris"
arch=('i686' 'x86_64')
url="http://www.pineight.com/lj"
license=('GPL')
-depends=('allegro' 'dumb')
+depends=('allegro4')
install=
# WARNING!!! This is not the original URL of the Lockjaw source code!
@@ -52,6 +52,10 @@ build() {
cd $srcdir
# Allegro gives us jpgalleg now... but the name in the makefile is wrong!
sed -i "s/jpgal/jpgalleg/" makefile
+ # It appears aldumb.h doesn't exist anymore, so we'll just not use it.
+ sed -i "s/-laldmb//" makefile
+ sed -i "s/-ldumb//" makefile
+ sed -i "s/LJMUSIC_USING_DUMB 1/LJMUSIC_USING_DUMB 0/" src/ljmusic.h
# -mwindows most definitely not supported by gcc and not what we want.
sed -i "s/-mwindows//" makefile
# In addition, I need an -lm otherwise cos is undefined