summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGene C2024-03-29 17:58:12 -0400
committerGene C2024-03-29 17:58:12 -0400
commit93f947e1b1f74829e7e18511e5afefb29aef7537 (patch)
treee683afeba4f2e4155c4856edc057ca95a4f30724
downloadaur-93f947e1b1f74829e7e18511e5afefb29aef7537.tar.gz
update project version 1.3.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11152148847b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lockmgr
+ pkgdesc = Python Lock Manager Class (gc)
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://github.com/gene-git/lockmgr
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-hatch
+ makedepends = rsync
+ depends = python>3.10
+ depends = pynotify
+ source = git+https://github.com/gene-git/lockmgr#tag=1.3.2
+ sha512sums = SKIP
+
+pkgname = lockmgr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57659085f027
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+#
+# Arch Linux PKGBUILD for lockmgr
+# This builds the latest release tag.
+# git HEAD is also well tested.
+#
+# Maintainer: Gene C <arch@sapience.com>
+# Contributor:
+#
+pkgname='lockmgr'
+pkgdesc='Python Lock Manager Class (gc)'
+_gitname='lockmgr'
+
+pkgver=1.3.2
+pkgrel=1
+url="https://github.com/gene-git/lockmgr"
+
+arch=(any)
+license=(MIT)
+
+# To build docs uncommont sphinx/texlive
+depends=('python>3.10' 'pynotify')
+makedepends=('git' 'python-build' 'python-wheel' 'python-hatch' 'rsync'
+ #'python-sphinx' 'python-myst-parser' 'texlive-latexextra'
+ )
+# Used by package : mkpkg
+_mkpkg_depends=('python>minor')
+
+source=("git+https://github.com/gene-git/${_gitname}#tag=${pkgver}")
+sha512sums=('SKIP')
+
+build() {
+ cd "${_gitname}"
+ /usr/bin/rm -f dist/*
+ /usr/bin/python -m build --wheel --no-isolation
+
+ # To build Docs
+ # uncomment these and sphinx makedepends above
+ # --------------
+ # echo "Build docs"
+ # cd ./Docs
+ # make html
+ # make latexpdf
+}
+
+package() {
+ cd "${_gitname}"
+ ./scripts/do-install ${pkgdir}
+}
+# vim:set ts=4 sts=4 sw=4 et: