summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2015-08-14 05:25:31 -0600
committeramagura2015-08-14 05:25:31 -0600
commit3532a4dfc7efd9e0ca0e7aad7fd7c71d330ce448 (patch)
treeb69fb3f40a10101be983d6a47492237acca4ae31
downloadaur-3532a4dfc7efd9e0ca0e7aad7fd7c71d330ce448.tar.gz
Initial reimport
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdde3d33696b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lockrun
+ pkgdesc = Exclusively run things via lock files
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/hilbix/lockrun
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://scylla-charybdis.com/download/lockrun-0.6.2-20110613-163042.tar.gz
+ md5sums = 304146202b9972ae9cb3afa37fe16c51
+
+pkgname = lockrun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ef3a8ddcdf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alexej Magura <alexej@Aya.localdomain>
+pkgname=lockrun
+pkgver=0.6.2
+_pkgver=20110613-163042
+pkgrel=1
+pkgdesc="Exclusively run things via lock files"
+arch=('i686' 'x86_64')
+url="https://github.com/hilbix/lockrun"
+license=('GPL')
+depends=('glibc')
+source=("http://scylla-charybdis.com/download/$pkgname-$pkgver-20110613-163042.tar.gz")
+md5sums=('304146202b9972ae9cb3afa37fe16c51')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver-$_pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver-$_pkgver"
+
+ install -Dm 755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: