summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Mischka2018-03-05 08:30:30 -0600
committerJacob Mischka2018-03-05 08:30:30 -0600
commit024048b96dfecc1c38ab67cc099111654eb20bc7 (patch)
treeb7bdd7846843cd5c383312c16ff7b4da43e991c8
parent751b1983b8107440a56028bd8978126a786243b9 (diff)
downloadaur-024048b96dfecc1c38ab67cc099111654eb20bc7.tar.gz
Fix arch and use XDG_DATA_HOME
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
-rw-r--r--loderunner.install2
4 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ed463ab55e3..fc4e75277404 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Mar 5 14:30:20 UTC 2018
pkgbase = loderunner
pkgdesc = Lode Runner Online: Mad Monks' Revenge. A puzzle video game from 1995
pkgver = 1.50
- pkgrel = 4
+ pkgrel = 5
url = http://www.daggert.net/Folio/Programming/Presage/LodeRunner/Loderunner1.htm
install = loderunner.install
arch = any
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ae12c5feadf3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.zip
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 1d0f3a16b9ba..e9d18dd0db14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
pkgname=loderunner
pkgver=1.50
-pkgrel=4
+pkgrel=5
pkgdesc="Lode Runner Online: Mad Monks' Revenge. A puzzle video game from 1995"
-arch=any
+arch=('any')
url=http://www.daggert.net/Folio/Programming/Presage/LodeRunner/Loderunner1.htm
license=('custom-freeware Abandonware')
depends=(wine winetricks unionfs-fuse xorg-xrefresh)
makedepends=(imagemagick)
options=(!strip)
install=$pkgname.install
+_install_dir=${XDG_DATA_HOME:-${HOME}/.local/share}/${pkgname}
source=(http://www.daggert.net/Folio/Programming/Presage/LodeRunner/Downloads/lro_install.zip)
md5sums=('ea39770395db0998b3dc3cad052a1977')
@@ -54,7 +55,7 @@ EOF
set -e
function atexit {
- fusermount -zu "\$HOME"/.$pkgname/lro/
+ fusermount -zu $_install_dir/lro/
xrefresh
echo "Goodbye from Lode Runner!"
exit 0
@@ -62,16 +63,15 @@ function atexit {
export WINEARCH=win32
export WINEDLLOVERRIDES="mscoree,mshtml="
-export WINEPREFIX="\$HOME"/.$pkgname/winefs
-export XDG_DATA_HOME=/dev/null
+export WINEPREFIX=$_install_dir/winefs
export WINEDEBUG=-all
echo "Starting..."
-if [ ! -d "\$HOME"/.$pkgname/ ] ;then
+if [ ! -d $_install_dir/ ] ;then
echo "Initializing the wine prefix."
- mkdir -p "\$HOME"/.$pkgname/lro
- cd "\$HOME"/.$pkgname/
+ mkdir -p $_install_dir/lro
+ cd $_install_dir
#setup wine prefix
mkdir lro_diff
wineboot -u
@@ -81,15 +81,15 @@ if [ ! -d "\$HOME"/.$pkgname/ ] ;then
cd winefs/dosdevices
ln -s ../../ x:
#copy support file
- cp /usr/share/$pkgname/SIERRA.INI "\$HOME"/.$pkgname/winefs/drive_c/windows/
+ cp /usr/share/$pkgname/SIERRA.INI $_install_dir/winefs/drive_c/windows/
sleep 5
fi
#mount lro at drive x:
-unionfs -o relaxed_permissions -o cow "\$HOME"/.$pkgname/lro_diff/=RW:/usr/share/$pkgname=RO "\$HOME"/.$pkgname/lro/
+unionfs -o relaxed_permissions -o cow $_install_dir/lro_diff/=RW:/usr/share/$pkgname=RO $_install_dir/lro/
trap atexit SIGHUP SIGINT SIGTERM EXIT
-cd "\$HOME"/.$pkgname/winefs/dosdevices/x:/lro/
+cd $_install_dir/winefs/dosdevices/x:/lro/
wine 'x:\lro\LODERUNN.EXE' "\$@" &>/dev/null
EOF
diff --git a/loderunner.install b/loderunner.install
index 55085e495afc..d69722ed9395 100644
--- a/loderunner.install
+++ b/loderunner.install
@@ -4,7 +4,7 @@ post_upgrade() {
echo
echo
echo
- echo 'Delete the ~/.loderunner directory when updating. Make sure to backup your config and save files.'
+ echo 'Delete the $XDG_DATA_HOME/.loderunner directory when updating. Make sure to backup your config and save files.'
echo
echo
echo