summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIdo Rosen2014-12-30 21:20:16 -0500
committerIdo Rosen2014-12-30 21:20:16 -0500
commit574d8aa9129bb282a6bedaae945896a3ed15553e (patch)
treef6f85f78b89069f077ad1e194994ff9d6955c154
downloadaur-574d8aa9129bb282a6bedaae945896a3ed15553e.tar.gz
Added ejabberd-git and log4cxx
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD28
-rw-r--r--log4cxx-0.10.0-missing_includes.patch38
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a53d62c594c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = log4cxx
+ pkgdesc = A C++ port of Log4j
+ pkgver = 0.10.0
+ pkgrel = 3
+ url = http://logging.apache.org/log4cxx
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = libtool
+ makedepends = patch
+ makedepends = zip
+ makedepends = gzip
+ makedepends = sed
+ depends = apr-util
+ depends = libxml2
+ source = http://archive.apache.org/dist/logging/log4cxx/0.10.0/apache-log4cxx-0.10.0.tar.gz
+ source = log4cxx-0.10.0-missing_includes.patch
+ md5sums = b30ffb8da3665178e68940ff7a61084c
+ md5sums = dfa17719a57b19f12cbef94419a2aac8
+
+pkgname = log4cxx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf722219b6e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=log4cxx
+pkgver=0.10.0
+pkgrel=3
+pkgdesc="A C++ port of Log4j"
+url="http://logging.apache.org/log4cxx"
+license="APACHE"
+depends=('apr-util' 'libxml2')
+arch=('i686' 'x86_64')
+makedepends=('autoconf' 'automake' 'libtool' 'patch' 'zip' 'gzip' 'sed')
+
+source=(http://archive.apache.org/dist/logging/$pkgname/$pkgver/apache-$pkgname-$pkgver.tar.gz
+ log4cxx-0.10.0-missing_includes.patch)
+md5sums=('b30ffb8da3665178e68940ff7a61084c'
+ 'dfa17719a57b19f12cbef94419a2aac8')
+
+build() {
+ cd "$srcdir/apache-$pkgname-$pkgver"
+
+ patch -p1 < $startdir/log4cxx-0.10.0-missing_includes.patch
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/apache-$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/log4cxx-0.10.0-missing_includes.patch b/log4cxx-0.10.0-missing_includes.patch
new file mode 100644
index 000000000000..9f3534ccc7e6
--- /dev/null
+++ b/log4cxx-0.10.0-missing_includes.patch
@@ -0,0 +1,38 @@
+diff -Naur apache-log4cxx-0.10.0.orig/src/examples/cpp/console.cpp apache-log4cxx-0.10.0/src/examples/cpp/console.cpp
+--- apache-log4cxx-0.10.0.orig/src/examples/cpp/console.cpp 2008-04-01 00:34:52.000000000 +0200
++++ apache-log4cxx-0.10.0/src/examples/cpp/console.cpp 2008-05-06 05:40:52.000000000 +0200
+@@ -15,7 +15,10 @@
+ * limitations under the License.
+ */
+
+-#include <stdlib.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
++#include <stdint.h>
+ #include <log4cxx/logger.h>
+ #include <log4cxx/consoleappender.h>
+ #include <log4cxx/simplelayout.h>
+diff -Naur apache-log4cxx-0.10.0.orig/src/main/cpp/inputstreamreader.cpp apache-log4cxx-0.10.0/src/main/cpp/inputstreamreader.cpp
+--- apache-log4cxx-0.10.0.orig/src/main/cpp/inputstreamreader.cpp 2008-04-01 00:34:09.000000000 +0200
++++ apache-log4cxx-0.10.0/src/main/cpp/inputstreamreader.cpp 2008-05-06 05:32:31.000000000 +0200
+@@ -21,6 +21,8 @@
+ #include <log4cxx/helpers/pool.h>
+ #include <log4cxx/helpers/bytebuffer.h>
+
++#include <cstring>
++
+ using namespace log4cxx;
+ using namespace log4cxx::helpers;
+
+diff -Naur apache-log4cxx-0.10.0.orig/src/main/cpp/socketoutputstream.cpp apache-log4cxx-0.10.0/src/main/cpp/socketoutputstream.cpp
+--- apache-log4cxx-0.10.0.orig/src/main/cpp/socketoutputstream.cpp 2008-04-01 00:34:09.000000000 +0200
++++ apache-log4cxx-0.10.0/src/main/cpp/socketoutputstream.cpp 2008-05-06 05:35:55.000000000 +0200
+@@ -20,6 +20,8 @@
+ #include <log4cxx/helpers/socket.h>
+ #include <log4cxx/helpers/bytebuffer.h>
+
++#include <cstring>
++
+ using namespace log4cxx;
+ using namespace log4cxx::helpers;