summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorakkenoth2018-12-22 23:25:57 +0100
committerakkenoth2018-12-22 23:25:57 +0100
commitaa2da1996ca84a068572a6f8b168952ef11e1ceb (patch)
treed971a46428c58a1efbfc7cbb20f9cb1d70a3d301
parent213d2756e03178e281f37d9472ab7558e2df78d6 (diff)
downloadaur-aa2da1996ca84a068572a6f8b168952ef11e1ceb.tar.gz
Updated git URL; bumped release to 2018-12-14 (171e980fdd31e09e36841cf82adcebfa12bcd6d0)
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9939c80972ef..0a189a9ca58b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Akkenoth <akkenoth+aur [at] google [dot] com>
pkgname=log4cxx-git
_pkgname=log4cxx
-pkgver=20180321
+pkgver=20181214
pkgrel=1
pkgdesc="A C++ port of Log4j, development version (GIT)"
url="http://logging.apache.org/log4cxx"
@@ -14,17 +14,23 @@ provides=('log4cxx')
conflicts=('log4cxx')
options=()
install=
-source=("${_pkgname}::git+https://git-wip-us.apache.org/repos/asf/logging-log4cxx.git#commit=5f825186936a1876f92b88b371334ff26e997287")
+source=("${_pkgname}::git+https://gitbox.apache.org/repos/asf/logging-log4cxx.git#commit=171e980fdd31e09e36841cf82adcebfa12bcd6d0")
md5sums=(SKIP)
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
./autogen.sh
./configure --prefix=/usr --disable-static
make
}
+# Check fails ATM
+#check() {
+# cd "${_pkgname}"
+# make -k check
+#}
+
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
make DESTDIR="${pkgdir}/" install
}