summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume ALAUX2015-07-05 15:34:29 +0200
committerGuillaume ALAUX2015-07-05 15:34:29 +0200
commit1b4eabc4a37357bbb3024763e0266f0ce568c496 (patch)
treeee39ca87c5dff52fe4e9f1bdf4671357d1dc4259
downloadaur-1b4eabc4a37357bbb3024763e0266f0ce568c496.tar.gz
Initial files 2.3
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..818d6027e3ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = log4j
+ pkgdesc = Logging library for Java
+ pkgver = 2.3
+ pkgrel = 1
+ url = http://logging.apache.org/log4j/
+ arch = any
+ license = APACHE
+ depends = java-runtime
+ source = https://archive.apache.org/dist/logging/log4j/2.3/apache-log4j-2.3-bin.tar.gz
+ sha256sums = a0118cccd0fa930705319b2ea031732f2eb6ce8802e3f696a294e3d3eec8c4aa
+
+pkgname = log4j
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..353683943f36
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar.xz
+*.src.tar.gz
+*.src.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccc09f2a5966
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Guillaume ALAUX <guillaume at archlinux dot org>
+pkgname=log4j
+pkgver=2.3
+pkgrel=1
+pkgdesc='Logging library for Java'
+arch=('any')
+url='http://logging.apache.org/log4j/'
+license=('APACHE')
+depends=('java-runtime')
+source=(https://archive.apache.org/dist/logging/${pkgname}/${pkgver}/apache-${pkgname}-${pkgver}-bin.tar.gz)
+sha256sums=('a0118cccd0fa930705319b2ea031732f2eb6ce8802e3f696a294e3d3eec8c4aa')
+
+package() {
+ cd "${srcdir}/apache-${pkgname}-${pkgver}-bin"
+
+ jars=$(find . \
+ -name "*.jar" -a ! -name "*-sources.jar" -a ! -name "*-javadoc.jar" -a ! -name "*-tests.jar")
+
+ for j in ${jars[@]}; do
+ install -D ${j} "${pkgdir}"/usr/share/java/${pkgname}/${j}
+ ln -s ${pkgname}/${j} ${pkgdir}/usr/share/java/${j/-$pkgver}
+ done
+}