summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-04-12 01:53:11 +0800
committerlilac2019-04-12 01:53:11 +0800
commitf69a0ff29aa0ade7f3cce59d92d0909ae6baff3b (patch)
tree1f6571cca373489b977e036b999463f1627c8c51
downloadaur-f69a0ff29aa0ade7f3cce59d92d0909ae6baff3b.tar.gz
update by lilac
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5187307e6230
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = logcat-color3
+ pkgdesc = A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK
+ pkgver = 0.9.0
+ pkgrel = 2
+ url = https://github.com/yan12125/logcat-color3
+ arch = any
+ license = Apache
+ makedepends = python-setuptools-scm
+ depends = python-colorama
+ conflicts = logcat-color
+ source = https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-0.9.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-0.9.0.tar.gz.asc
+ validpgpkeys = 481C4474AF1572165AE4C6AF3FDDD575826C5C30
+ sha256sums = 57471841b59d0a456f6d3a971bb3701ca2fc9a8319735e9515c9de3cd2062c92
+ sha256sums = SKIP
+
+pkgname = logcat-color3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7df631607bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: Thomas Weißschuh <thomas t-8ch de>
+
+pkgname=logcat-color3
+pkgver=0.9.0
+pkgrel=2
+pkgdesc='A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK'
+arch=(any)
+url='https://github.com/yan12125/logcat-color3'
+license=(Apache)
+depends=(python-colorama)
+makedepends=(python-setuptools-scm)
+conflicts=(logcat-color)
+source=("https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-$pkgver.tar.gz"{,.asc})
+sha256sums=('57471841b59d0a456f6d3a971bb3701ca2fc9a8319735e9515c9de3cd2062c92'
+ 'SKIP')
+validpgpkeys=(
+ '481C4474AF1572165AE4C6AF3FDDD575826C5C30' # Chih-Hsuan Yen <yan12125@gmail.com>
+)
+
+build() {
+ cd logcat-color3-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd logcat-color3-$pkgver
+ python test/test.py
+}
+
+package() {
+ cd logcat-color3-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}