summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2014-11-15 12:14:00 +0100
committerNicolas Iooss2015-06-27 11:44:58 +0800
commitf7b3799ab76cd9c902dd15eb7208d75322f73165 (patch)
tree9688e0a9d669e80ba58659d891edf0bf6ea587e1
parent2889bc01c6d563e6d7d4bb8e98f7b8656b79279d (diff)
downloadaur-f7b3799ab76cd9c902dd15eb7208d75322f73165.tar.gz
logrotate-selinux 3.8.8-1 update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44ee19dfc265..112fe692676f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = logrotate-selinux
pkgdesc = Rotates system logs automatically with SELinux support
- pkgver = 3.8.7
+ pkgver = 3.8.8
pkgrel = 1
url = https://fedorahosted.org/logrotate/
arch = i686
@@ -11,18 +11,17 @@ pkgbase = logrotate-selinux
depends = gzip
depends = acl
depends = libselinux
- optdepends = cron: scheduled log rotation
- provides = logrotate=3.8.7-1
- provides = selinux-logrotate=3.8.7-1
+ provides = logrotate=3.8.8-1
+ provides = selinux-logrotate=3.8.8-1
conflicts = logrotate
conflicts = selinux-logrotate
backup = etc/logrotate.conf
- source = https://fedorahosted.org/releases/l/o/logrotate/logrotate-3.8.7.tar.gz
+ source = https://fedorahosted.org/releases/l/o/logrotate/logrotate-3.8.8.tar.gz
source = paths.patch
source = logrotate.conf
source = logrotate.timer
source = logrotate.service
- md5sums = 99e08503ef24c3e2e3ff74cc5f3be213
+ md5sums = 49846e873dddea15964cd0355b9943ca
md5sums = e76526bcd6fc33c9d921e1cb1eff1ffb
md5sums = 94dae4d3eded2fab9ae879533d3680db
md5sums = 287c2ad9b074cb5478db7692f385827c
diff --git a/PKGBUILD b/PKGBUILD
index 3d49c03fb0f2..095d119bacc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgname=logrotate-selinux
-pkgver=3.8.7
+pkgver=3.8.8
pkgrel=1
pkgdesc="Rotates system logs automatically with SELinux support"
arch=('i686' 'x86_64')
@@ -11,7 +11,6 @@ url="https://fedorahosted.org/logrotate/"
license=('GPL')
groups=('selinux')
depends=('popt' 'gzip' 'acl' 'libselinux')
-optdepends=('cron: scheduled log rotation')
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
@@ -20,7 +19,7 @@ source=("https://fedorahosted.org/releases/l/o/logrotate/logrotate-${pkgver}.tar
'paths.patch'
'logrotate.conf'
logrotate.{timer,service})
-md5sums=('99e08503ef24c3e2e3ff74cc5f3be213'
+md5sums=('49846e873dddea15964cd0355b9943ca'
'e76526bcd6fc33c9d921e1cb1eff1ffb'
'94dae4d3eded2fab9ae879533d3680db'
'287c2ad9b074cb5478db7692f385827c'
@@ -31,7 +30,14 @@ build() {
patch -p0 -i "$srcdir/paths.patch"
- make WITH_ACL=yes WITH_SELINUX=yes RPM_OPT_FLAGS="$CFLAGS" EXTRA_LDFLAGS="$LDFLAGS"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --mandir=/usr/share/man \
+ --with-acl \
+ --with-selinux
+ make
}
check() {
@@ -41,8 +47,8 @@ check() {
package() {
cd "$srcdir/${pkgname/-selinux}-${pkgver}"
- make PREFIX="$pkgdir" MANDIR="/usr/share/man" install
- mv ${pkgdir}/usr/sbin ${pkgdir}/usr/bin
+
+ make DESTDIR="$pkgdir" install
install -dm755 "$pkgdir/etc/logrotate.d"
install -Dm644 "$srcdir/logrotate.conf" "$pkgdir/etc/logrotate.conf"