summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:59:18 +0200
committeroli2015-06-12 21:59:18 +0200
commit0ea5d85165886460a6f619d6fa1ea5b93260548c (patch)
tree187709cae3aeca527567bbcf8fd9a1475df5b3d8
downloadaur-0ea5d85165886460a6f619d6fa1ea5b93260548c.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51898f775916
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = logsend
+ pkgdesc = tool for sending e-mail notifications about changes in (log) files
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://logsend.sourceforge.net
+ arch = any
+ license = GPL
+ depends = bash
+ depends = inotify-tools
+ source = http://downloads.sourceforge.net/logsend/logsend-1.0.tar.gz
+ md5sums = e6de052161c3d553391f99620027a33b
+
+pkgname = logsend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2cd76f5a9b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: jose <jose1711 [at] gmail (dot) com>
+
+pkgname=logsend
+pkgver=1.0
+pkgrel=1
+pkgdesc="tool for sending e-mail notifications about changes in (log) files"
+arch=('any')
+url="http://logsend.sourceforge.net"
+license=('GPL')
+depends=('bash' 'inotify-tools')
+source=("http://downloads.sourceforge.net/logsend/${pkgname}-${pkgver}.tar.gz")
+md5sums=('e6de052161c3d553391f99620027a33b')
+
+build() {
+sed -i 's/DESTDIR="${prefix}\/${ORV_PKG_NAME}"/DESTDIR="${prefix}"\/usr/' $srcdir/$pkgname-$pkgver/install.sh
+}
+
+package() {
+cd $srcdir/$pkgname-$pkgver
+prefix=$pkgdir/ make install
+find $pkgdir/ -exec chown root '{}' \;
+sed -i '/^DESTDIR=/s/.*/DESTDIR="\/usr"/' $pkgdir/usr/bin/logsend
+sed -i 's/\$"\([57]\)"/$\1/' $pkgdir/usr/lib/logsend-1.0/logsend-config
+}