aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Moser2019-04-20 16:34:07 +0200
committerFlorian Moser2019-04-20 16:34:07 +0200
commit86c84803a6dc8b5f07221ede2a8fbfb9ed9c1864 (patch)
tree04de459fd413dc74976dfc2da865f2ca5c9ed07a
parentaa146df5e86ffff76b57ed3ac9e1f15eb0a19ef2 (diff)
downloadaur-86c84803a6dc8b5f07221ede2a8fbfb9ed9c1864.tar.gz
add CI setup
-rw-r--r--.gitignore3
-rw-r--r--.travis.yml18
-rw-r--r--LICENSE21
-rw-r--r--README.md14
4 files changed, 56 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c5094f302875
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+lokalise*.tar* \ No newline at end of file
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..995ee1badf6b
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,18 @@
+sudo: required
+
+services:
+ - docker
+
+arch:
+ packages:
+ - namcap
+ script:
+ - "PKGEXT='.pkg.tar' makepkg -si --noconfirm"
+ - "namcap PKGBUILD"
+ - "namcap lokalise*.pkg*"
+
+script:
+ - "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
+
+notifications:
+ email: false \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1cc5efdd4d5d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Florian Moser
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..c04038194c76
--- /dev/null
+++ b/README.md
@@ -0,0 +1,14 @@
+# Lokalise AUR Package
+[![Build Status](https://travis-ci.org/famoser/lokalise-aur.svg?branch=master)](https://travis-ci.org/famoser/lokalise-aur)
+
+## Prepare arch upstream
+
+
+## Update package
+
+1. Update package version in PKGBUILD
+2. Generate new checksums with `updpkgsums`
+3. Test install `makepkg -si`
+4. Update .SRCINFO `makepkg --printsrcinfo > .SRCINFO`
+5. `git remote add arch ssh://aur@aur.archlinux.org/lokalise.git`
+6. `git push arch` \ No newline at end of file