summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornekgem2020-05-06 15:52:14 +0300
committernekgem2020-05-06 15:52:14 +0300
commit04313083eac52711cf8a55379b2ac80044f3693c (patch)
treeed37ea7dd46aae15060e4ef3ec4159efa7086e96
parent93d261cb3c2e84f5155aaa06cda707fb843e9509 (diff)
downloadaur-04313083eac52711cf8a55379b2ac80044f3693c.tar.gz
disable submodule checks as these should be always up-to-date in our case
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28789102314f..3a7c06e555cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
# Maintainer: nekgem <nekgem@cock.li>
pkgname=lokinet
-_gitname=loki-network
pkgver=0.7.1
pkgrel=1
pkgdesc="Anonymous, decentralized and IP based overlay network for the internet."
@@ -10,6 +9,7 @@ license=('ZLIB')
depends=('libuv' 'libsodium' 'curl')
makedepends=('git' 'cmake')
install='lokinet.install'
+_gitname=loki-network
source=("git+https://github.com/loki-project/$_gitname.git#tag=v$pkgver" # github archives don't embed submodules
'lokinet.service'
'lokinet-bootstrap.service'
@@ -46,6 +46,7 @@ build() {
-DWITH_SHARED=OFF \
-DWITH_TESTS=OFF \
-DDOWNLOAD_SODIUM=OFF \
+ -DSUBMODULE_CHECK=OFF \
-Wno-dev \
..
make