summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-21 19:50:08 -0800
committerclintval2018-01-21 19:50:08 -0800
commitb1e2b799670301929d3e2dd741af2e5ade1b67c2 (patch)
treeeab3531e16504c342053113d8a8c9d0ebd070e06
downloadaur-lollipops-bin.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ef8a313dfdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lollipops-bin
+ pkgdesc = Lollipop-style mutation diagrams for annotating genetic variations
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://github.com/pbnjay/lollipops
+ arch = any
+ license = GPL3
+ provides = lollipops
+ conflicts = lollipops
+ options = !emptydirs
+ source = https://github.com/pbnjay/lollipops/releases/download/v1.3.2/lollipops-v1.3.2-linux64.tar.gz
+ sha256sums = 8f007204b00595ec750e1eee93ebcfa1522867d4387aaef4f24cfe56d5991bbb
+
+pkgname = lollipops-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18bdcee20e64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=lollipops-bin
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Lollipop-style mutation diagrams for annotating genetic variations"
+arch=('any')
+url=https://github.com/pbnjay/lollipops
+license=('GPL3')
+provides=('lollipops')
+conflicts=('lollipops')
+options=(!emptydirs)
+source=(https://github.com/pbnjay/"${pkgname//-bin/}"/releases/download/v"${pkgver}"/"${pkgname//-bin/}"-v"${pkgver}"-linux64.tar.gz)
+sha256sums=('8f007204b00595ec750e1eee93ebcfa1522867d4387aaef4f24cfe56d5991bbb')
+
+package() {
+ cd "${srcdir}"/"${pkgname//-bin/}"-v"${pkgver}"-linux64
+ install -Dm655 README.md "${pkgdir}"/usr/share/doc/"${pkgname//-bin/}"/README.md
+ install -Dm655 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname//-bin/}"/LICENSE
+ install -Dm755 "${pkgname//-bin/}" "${pkgdir}"/usr/bin/"${pkgname//-bin/}"
+}