summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2017-07-05 17:13:44 +0200
committerFrederic Bezies2017-07-05 17:13:44 +0200
commitfd30025087c28b901773d843a1ced9f2c36cab2e (patch)
tree16b6333d01ed0db7d78d5bb0006a8b63c4caa33d
parent0aeebc359af3f692f6a00db4e7f49971a69ba61a (diff)
downloadaur-fd30025087c28b901773d843a1ced9f2c36cab2e.tar.gz
meson and ninja building tool transition
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9745c4688a35..6317b4544183 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 30 06:47:10 UTC 2017
+# Wed Jul 5 15:13:25 UTC 2017
pkgbase = lollypop-git
pkgdesc = Music player for GNOME
- pkgver = 0.9.240.r19.g9e24463b
+ pkgver = 0.9.242.r2.gcdfd1319
pkgrel = 1
url = https://github.com/gnumdk/lollypop
arch = i686
@@ -15,6 +15,8 @@ pkgbase = lollypop-git
makedepends = python
makedepends = yelp-tools
makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = appstream-glib
depends = desktop-file-utils
depends = gst-python
depends = gtk3
@@ -22,15 +24,15 @@ pkgbase = lollypop-git
depends = python-dbus
depends = python-gobject
depends = totem-plparser
+ depends = python-pylast
optdepends = easytag: tag editing
optdepends = flatpak: Flatpak Portal
optdepends = gst-libav: FFmpeg plugin for GStreamer
optdepends = kid3-qt: Store covers in tags
optdepends = libsecret: Last.FM support
- optdepends = python-pylast: Last.FM support
optdepends = python-wikipedia: Wikipedia support
optdepends = youtube-dl: YouTube playback
- provides = lollypop=0.9.240.r19.g9e24463b
+ provides = lollypop=0.9.242.r2.gcdfd1319
conflicts = lollypop
options = !emptydirs
source = git://github.com/gnumdk/lollypop.git
diff --git a/PKGBUILD b/PKGBUILD
index b4c09257decd..f60d6a8775bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lollypop-git
_gitname=lollypop
-pkgver=0.9.240.r19.g9e24463b
+pkgver=0.9.242.r2.gcdfd1319
_portal_pkgver=0.9.1
pkgrel=1
pkgdesc='Music player for GNOME'
@@ -11,14 +11,13 @@ arch=('i686' 'x86_64')
license=('GPL3')
url="https://github.com/gnumdk/${_gitname}"
depends=('desktop-file-utils' 'gst-python' 'gtk3' 'python-cairo'
- 'python-dbus' 'python-gobject' 'totem-plparser')
-makedepends=('git' 'gnome-common' 'intltool' 'itstool' 'python' 'yelp-tools' 'gobject-introspection')
+ 'python-dbus' 'python-gobject' 'totem-plparser' 'python-pylast')
+makedepends=('git' 'gnome-common' 'intltool' 'itstool' 'python' 'yelp-tools' 'gobject-introspection' 'meson' 'appstream-glib')
optdepends=('easytag: tag editing'
'flatpak: Flatpak Portal'
'gst-libav: FFmpeg plugin for GStreamer'
'kid3-qt: Store covers in tags'
'libsecret: Last.FM support'
- 'python-pylast: Last.FM support'
'python-wikipedia: Wikipedia support'
'youtube-dl: YouTube playback')
options=('!emptydirs')
@@ -42,8 +41,9 @@ build() {
make
cd "$srcdir/${_gitname}"
- ./autogen.sh --prefix=/usr --disable-schemas-compile
- make
+ rm -rf _build
+ /usr/bin/meson _build --prefix=/usr
+ ninja -C _build
}
package() {
@@ -51,6 +51,5 @@ package() {
make DESTDIR="${pkgdir}" install
cd "$srcdir/${_gitname}"
- make DESTDIR="${pkgdir}" install
- #chmod +x $pkgdir/usr/share/lollypop/lollypop-sp
+ env DESTDIR="$pkgdir" ninja -C _build install
}