summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-05-10 01:32:54 +0200
committerLW-archlinux2019-05-10 01:32:54 +0200
commit6c68d5c7f00e39ab242d929d9f39b32cd1587b76 (patch)
tree4d1ba89471650212992ed420a994d2d6ee2cadc3
parentfcc00a9979bc652e7b63393e66f630053d1f376d (diff)
downloadaur-6c68d5c7f00e39ab242d929d9f39b32cd1587b76.tar.gz
remove unneeded parts of sourcecode
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fdf6d76b02a..2a2aae3ccd9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lone_wolf-clang-git
pkgdesc = C language family frontend for LLVM
- pkgver = 9.0.0_r315711.5ab41a7a055
+ pkgver = 9.0.0_r316130.bd588dfd594
pkgrel = 1
url = https://clang.llvm.org/
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = lone_wolf-clang-git
optdepends = openmp: OpenMP support in clang with -fopenmp
optdepends = python: for scan-view and git-clang-format
optdepends = llvm-libs: for LLVMGOLD support
- provides = clang=9.0.0_r315711.5ab41a7a055-1
+ provides = clang=9.0.0_r316130.bd588dfd594-1
conflicts = clang
source = llvm-project::git+https://github.com/llvm/llvm-project.git
source = enable-SSP-and-PIE-by-default.patch
diff --git a/PKGBUILD b/PKGBUILD
index f2d575ddab9e..d706c2cff8b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@
# Contributor: Tomas Wilhelmsson <tomas.wilhelmsson@gmail.com>
pkgname=lone_wolf-clang-git
-pkgver=9.0.0_r315711.5ab41a7a055
+pkgver=9.0.0_r316130.bd588dfd594
pkgrel=1
pkgdesc="C language family frontend for LLVM"
arch=('x86_64')
@@ -49,7 +49,10 @@ pkgver() {
}
prepare() {
- cd llvm-project/clang
+ cd llvm-project
+ # remove unneedede parts of sourcecode
+ rm -rf compiler-rt debuginfo-tests libclc libcxx libcxxabi libunwind lld lldb llgo openmp parallel-libs polly pstl
+ cd clang
mv "$srcdir"/llvm-project/clang-tools-extra tools/extra
sed -i "s/add_clang_executable/add_clang_tool/g" tools/extra/clangd/indexer/CMakeLists.txt
patch -Np1 -i ../../enable-SSP-and-PIE-by-default.patch
@@ -65,6 +68,7 @@ build() {
cmake "$srcdir"/llvm-project/clang/ -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DBUILD_SHARED_LIBS=ON \
-DLLVM_LINK_LLVM_DYLIB=ON \
-DLLVM_ENABLE_RTTI=ON \
@@ -75,7 +79,10 @@ build() {
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
-DLLVM_EXTERNAL_LIT=/usr/bin/lit \
-DLLVM_MAIN_SRC_DIR="$srcdir"/llvm-project/llvm \
- -DLLVM_VERSION_SUFFIX=""
+ -DLLVM_VERSION_SUFFIX="" \
+ -DCMAKE_POLICY_DEFAULT_CMP0077=NEW
+
+
if [[ ! $NINJAFLAGS ]]; then
ninja
else