summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlie Ringström2021-01-09 14:35:34 +0100
committerCharlie Ringström2021-01-09 14:35:34 +0100
commit54f4a0a9e5b45ce5b3b8f6cea9cec87f7fbd0e8b (patch)
treeec164d717922db25a0e1db6a3e06b11324e739ca
downloadaur-54f4a0a9e5b45ce5b3b8f6cea9cec87f7fbd0e8b.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7b1dd9f134b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = longcat
+ pkgdesc = Creates a loooonng cat in the terminal
+ pkgver = r112.a13f8d2
+ pkgrel = 1
+ url = https://github.com/mattn/longcat
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ depends = glibc
+ source = longcat::git://github.com/mattn/longcat.git
+ md5sums = SKIP
+
+pkgname = longcat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e0e8bb62c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Charlie Ringström <c.ringstrom@gmail.com>
+pkgname='longcat'
+pkgver=r112.a13f8d2
+pkgrel=1
+pkgdesc="Creates a loooonng cat in the terminal"
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/mattn/longcat"
+license=('MIT')
+depends=('glibc')
+makedepends=('go')
+#changelog="Initial release"
+source=("longcat::git://github.com/mattn/longcat.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o longcat
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 ./longcat "$pkgdir"/usr/bin/$pkgname
+}