diff options
author | Aryan Kothariset -g allow-passthrough on | 2025-02-24 12:40:19 -0500 |
---|---|---|
committer | Aryan Kothariset -g allow-passthrough on | 2025-02-24 12:40:19 -0500 |
commit | 725383f8a0661b32b8a549fa26dac546f25a641e (patch) | |
tree | 0ef7efe4c347f5385b89aa6c4df837f63b20ce2f | |
parent | af3a5b367d33c5e8c708255a18440bc91324e2d7 (diff) | |
download | aur-725383f8a0661b32b8a549fa26dac546f25a641e.tar.gz |
update pkg
-rw-r--r-- | PKGBUILD | 22 |
1 files changed, 11 insertions, 11 deletions
@@ -1,6 +1,6 @@ # Maintainer: Aryan Kothari aryan@aryankothari.dev pkgname=longhorn-backup-repacker -pkgver=v1.1.2 +pkgver=1.1.4 pkgrel=1 pkgdesc="A tool to repack Longhorn backup files" arch=('any') @@ -9,21 +9,21 @@ license=('MIT') depends=('go') makedepends=('git') -source=("-.tar.gz::https://github.com/thearyadev//archive/v.tar.gz") +source=("$pkgname-\$pkgver.tar.gz::https://github.com/thearyadev/\$pkgname/archive/v\$pkgver.tar.gz") sha256sums=('SKIP') build() { - cd "-" - export CGO_CPPFLAGS="" - export CGO_CFLAGS="" - export CGO_CXXFLAGS="" - export CGO_LDFLAGS="" + cd "$pkgname-\$pkgver" + export CGO_CPPFLAGS="${CPPFLAGS}" + export CGO_CFLAGS="${CFLAGS}" + export CGO_CXXFLAGS="${CXXFLAGS}" + export CGO_LDFLAGS="${LDFLAGS}" export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" - go build -o "-X main.version= (aur)" . + go build -o $pkgname "-X main.version=\$pkgver (aur)" . } package() { - cd "-" - sudo install -Dm755 "" "/usr/bin/" - sudo install -Dm644 LICENSE "/usr/share/licenses//LICENSE" + cd "$pkgname-\$pkgver" + sudo install -Dm755 "$pkgname" "/usr/bin/\$pkgname" + sudo install -Dm644 LICENSE "/usr/share/licenses/$pkgname/LICENSE" } |