diff options
author | thearyadev | 2025-02-24 16:42:45 +0000 |
---|---|---|
committer | thearyadev | 2025-02-24 16:42:45 +0000 |
commit | dc3187495b9df50f91566cf1033f181923fed2d5 (patch) | |
tree | 4f6d053bfbeccae92463d2b7517e9d72be5c3a12 | |
parent | 33448d83bda3fe6e6014d16d11c4167dff977639 (diff) | |
download | aur-dc3187495b9df50f91566cf1033f181923fed2d5.tar.gz |
Update AUR package
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 26 |
2 files changed, 14 insertions, 16 deletions
@@ -1,13 +1,13 @@ pkgbase = longhorn-backup-repacker pkgdesc = A tool to repack Longhorn backup files - pkgver = 1.1.0 + pkgver = v1.1.1 pkgrel = 1 url = https://github.com/thearyadev/longhorn-backup-repacker arch = any license = MIT makedepends = git depends = go - source = longhorn-backup-repacker-1.1.0.tar.gz::https://github.com/thearyadev/longhorn-backup-repacker/archive/v1.1.0.tar.gz + source = -.tar.gz::https://github.com/thearyadev//archive/v.tar.gz sha256sums = SKIP pkgname = longhorn-backup-repacker @@ -1,6 +1,6 @@ # Maintainer: Aryan Kothari aryan@aryankothari.dev pkgname=longhorn-backup-repacker -pkgver=1.1.0 +pkgver=v1.1.1 pkgrel=1 pkgdesc="A tool to repack Longhorn backup files" arch=('any') @@ -9,23 +9,21 @@ license=('MIT') depends=('go') makedepends=('git') -source=("$pkgname-$pkgver.tar.gz::https://github.com/thearyadev/$pkgname/archive/v$pkgver.tar.gz") -sha256sums=('SKIP') # Replace with actual SHA256 sum of your source file +source=("-.tar.gz::https://github.com/thearyadev//archive/v.tar.gz") +sha256sums=('SKIP') build() { - cd "$pkgname-$pkgver" - export CGO_CPPFLAGS="${CPPFLAGS}" - export CGO_CFLAGS="${CFLAGS}" - export CGO_CXXFLAGS="${CXXFLAGS}" - export CGO_LDFLAGS="${LDFLAGS}" + cd "-" + export CGO_CPPFLAGS="" + export CGO_CFLAGS="" + export CGO_CXXFLAGS="" + export CGO_LDFLAGS="" export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" - go build -o $pkgname . + go build -o . } package() { - cd "$pkgname-$pkgver" - sudo install -Dm755 "$pkgname" "/usr/bin/$pkgname" - - # # Install license if you have one - sudo install -Dm644 LICENSE "/usr/share/licenses/$pkgname/LICENSE" + cd "-" + sudo install -Dm755 "" "/usr/bin/" + sudo install -Dm644 LICENSE "/usr/share/licenses//LICENSE" } |