summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2023-05-08 10:14:26 +0000
committerOmar Pakker2023-05-08 10:14:26 +0000
commit638f26db3d4aa6a525daf762d0c0177c4a6221d5 (patch)
tree414d8edd44a401d4a445ac70c1438ca5e075bb2e
parent6f3005aaf645e5f80ffdc02984bae0f227b28922 (diff)
downloadaur-638f26db3d4aa6a525daf762d0c0177c4a6221d5.tar.gz
Quick (and slightly dirty..) work-around for host build failure.
Cause seems to be the gcc 12->13 change.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82a595fc704a..e15a21bc8d8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = looking-glass
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
pkgver = B6
- pkgrel = 4
+ pkgrel = 5
epoch = 2
url = https://looking-glass.io/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 541cc368f891..94569a2f82b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=("${pkgbase}"
"obs-plugin-${pkgbase}")
epoch=2
pkgver=B6
-pkgrel=4
+pkgrel=5
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.io/"
arch=('x86_64')
@@ -20,6 +20,11 @@ sha512sums=('558981d6b32098076ef0775a748da349941551352cbef836e37310e43e5cd6072df
_lgdir="${pkgbase}-${pkgver}"
+prepare() {
+ sed -i '1 i\#pragma GCC diagnostic ignored "-Wmaybe-uninitialized"' \
+ "${srcdir}/${_lgdir}/host/platform/Linux/capture/pipewire/src/portal.c"
+}
+
build() {
cd "${srcdir}/${_lgdir}"
for b in {client,host,obs}/build; do