summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2019-06-16 11:02:35 +0000
committerOmar Pakker2019-06-16 11:02:35 +0000
commit6f70a922bfdb3bf76d997b8be6ec9bb9f0481e59 (patch)
treed19312af77934229e5a6f04a9169cdb6fc421def
parent78de80b3ee607d4d26755669a0e6a0cc0dda1cd9 (diff)
downloadaur-6f70a922bfdb3bf76d997b8be6ec9bb9f0481e59.tar.gz
Add patch for kvmfr kernel module to allow for correct DKMS builds.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2838488e7b96..842c5e553189 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = looking-glass
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
pkgver = B1_rc5
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://looking-glass.hostfission.com
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = looking-glass
makedepends = fontconfig
makedepends = spice-protocol
source = https://github.com/gnif/LookingGlass/archive/B1-rc5.tar.gz
+ source = https://github.com/gnif/LookingGlass/pull/167.diff
sha512sums = 5e4539d7decbfb37e8eb481c5d27cc38c1d7ed65df5e49a64f9a14402243b9f9ee97c939d3733bd90859ded71961a866c627d3c6c44bff6bd36881eced1fc1ec
+ sha512sums = 9523fc209fc9fa1ff19a325d89146c14d2806ed2401493a5a00f553749a7db3681ef6450148182c50f9a6716a2084cf506f04523b94afccacd6acb3afe83b077
pkgname = looking-glass
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
diff --git a/PKGBUILD b/PKGBUILD
index af6073a8ee18..40d21862d7f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,21 @@ pkgname=("${pkgbase}" "${pkgbase}-module-dkms" "${pkgbase}-host")
epoch=1
pkgver=B1_rc5
_pkgver=${pkgver//_/-}
-pkgrel=2
+pkgrel=3
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.hostfission.com"
arch=('x86_64')
license=('GPL2')
makedepends=('cmake' 'sdl2_ttf' 'glu' 'fontconfig' 'spice-protocol')
-source=("https://github.com/gnif/LookingGlass/archive/${_pkgver}.tar.gz")
-sha512sums=('5e4539d7decbfb37e8eb481c5d27cc38c1d7ed65df5e49a64f9a14402243b9f9ee97c939d3733bd90859ded71961a866c627d3c6c44bff6bd36881eced1fc1ec')
+source=("https://github.com/gnif/LookingGlass/archive/${_pkgver}.tar.gz"
+ "https://github.com/gnif/LookingGlass/pull/167.diff")
+sha512sums=('5e4539d7decbfb37e8eb481c5d27cc38c1d7ed65df5e49a64f9a14402243b9f9ee97c939d3733bd90859ded71961a866c627d3c6c44bff6bd36881eced1fc1ec'
+ '9523fc209fc9fa1ff19a325d89146c14d2806ed2401493a5a00f553749a7db3681ef6450148182c50f9a6716a2084cf506f04523b94afccacd6acb3afe83b077')
+
+prepare() {
+ cd "${srcdir}/LookingGlass-${_pkgver}"
+ patch -p1 < "${srcdir}/167.diff"
+}
build() {
cd "${srcdir}/LookingGlass-${_pkgver}"