summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2021-07-05 10:44:43 +0000
committerOmar Pakker2021-07-05 10:44:43 +0000
commit790aafb57b814d799c63cdef4f6fbd78174b2067 (patch)
tree708c8815e2221e5e54983e9fc76be1907548e414
parenta5194b94ac90b37b09c6dc5fc5d3c809ce053158 (diff)
downloadaur-790aafb57b814d799c63cdef4f6fbd78174b2067.tar.gz
Include patch to fix resulting build's version info.
The resulting build version is currently broken for builds being performed inside a git repo other than a looking-glass clone. This upstream patch resolves this by prioritizing the VERSION file, included in the packaged release, over executing a `git` command.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd9b057ab1f7..edadf33d8cba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = looking-glass
pkgdesc = An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough
pkgver = B3
- pkgrel = 1
+ pkgrel = 2
epoch = 2
url = https://looking-glass.io/
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = looking-glass
makedepends = libxi
makedepends = obs-studio
source = looking-glass-B3.tar.gz::https://looking-glass.io/ci/host/source?id=551
+ source = version-fix.patch::https://github.com/gnif/LookingGlass/commit/6c545806abc5441be994a1f9315cfd75d4b89682.diff
sha512sums = a76e4b373c53bd2cb87d8ab6179da47567ac75c9144c74c6df212e9cb3f4b929be8901163e3b6fc04b54a1ae6a5c10815b7ee921ceab1aa9a3df2cb9b0b82a2c
+ sha512sums = 729252c6cb346d9f78b4c6d8a1aa6d9991a2fa683e2b77168d09aaf9eec37621d418828330db63b1f786d86014449d5f4f807607483654f5927867e6e7aecca1
pkgname = looking-glass
pkgdesc = A client application for accessing the LookingGlass IVSHMEM device of a VM
@@ -37,4 +39,3 @@ pkgname = looking-glass-host
pkgname = obs-plugin-looking-glass
pkgdesc = Plugin for OBS Studio to stream directly from Looking Glass without having to record the Looking Glass client
depends = obs-studio
-
diff --git a/PKGBUILD b/PKGBUILD
index dc3415ce1e84..11df8d9593ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,18 +7,27 @@ pkgname=("${pkgbase}"
"obs-plugin-${pkgbase}")
epoch=2
pkgver=B3
-pkgrel=1
+pkgrel=2
pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
url="https://looking-glass.io/"
arch=('x86_64')
license=('GPL2')
makedepends=('cmake' 'sdl2_ttf' 'fontconfig' 'spice-protocol' 'wayland-protocols'
'libxss' 'libxi' 'obs-studio')
-source=("looking-glass-${pkgver}.tar.gz::https://looking-glass.io/ci/host/source?id=551")
-sha512sums=('a76e4b373c53bd2cb87d8ab6179da47567ac75c9144c74c6df212e9cb3f4b929be8901163e3b6fc04b54a1ae6a5c10815b7ee921ceab1aa9a3df2cb9b0b82a2c')
+source=("looking-glass-${pkgver}.tar.gz::https://looking-glass.io/ci/host/source?id=551"
+ "version-fix.patch::https://github.com/gnif/LookingGlass/commit/6c545806abc5441be994a1f9315cfd75d4b89682.diff")
+sha512sums=('a76e4b373c53bd2cb87d8ab6179da47567ac75c9144c74c6df212e9cb3f4b929be8901163e3b6fc04b54a1ae6a5c10815b7ee921ceab1aa9a3df2cb9b0b82a2c'
+ '729252c6cb346d9f78b4c6d8a1aa6d9991a2fa683e2b77168d09aaf9eec37621d418828330db63b1f786d86014449d5f4f807607483654f5927867e6e7aecca1')
_lgdir="looking-glass-B3-0-g2973319bff"
+prepare() {
+ cd "${srcdir}/${_lgdir}"
+
+ # https://aur.archlinux.org/pkgbase/looking-glass/#comment-815934
+ patch -Np1 < "${srcdir}/version-fix.patch"
+}
+
build() {
cd "${srcdir}/${_lgdir}"
for b in {client,host,obs}; do